Servers by jDrones

Arduboat with 3.5m boat and yamaha 6hp engine

(Canterobb) #1

Hello, after a long time of reading many topics in this forum I have dared to create a new topic.

I decided to build a boat with a gasoline engine after seeing this

although in my design, I made some modifications to be able to use my boat in waters with a bit of waves.

I built the boat with a length of 3.5 meters, and I used a yamaha 6hp engine that I already had.

the electronics so far is very simple, a pixhawk 2.1 with ardurover 3.5, a pair of radio rfd900, a taranis x9d and a pair of bec.

The accelerator is in charge of a servo savox of high torque and waterprof.

I have done tests in the sea in 2 occasions with the control in manual form, the first time it did not work very well, because for steering control I used a servo that although it had a lot of force was very slow.

8 "Stroke: 115 lb Thrust Linear Servo

https://www.servocity.com/hdls-8-50-12v

This servo did not protect it well and finally it was damaged by salt water.

then I asked for another servo similar, a little faster and with a little less push

8 "Stroke: 25 lb Thrust Linear Servo

https://www.servocity.com/hdls-8-2-12v

also perfect the place where the servo is located so that no water enters and install a teleflex to transmit the thrust of the servo to the motor.

on this occasion the boat worked very well manually, I had complete control of the movements, this was very nice.

although in an automatic way it did not work very well, it was normal to adjust the autopilot, so I took the boat out of the water and returned happily to my house with the intention of the next day to continue the tests, but made the mistake of leaving the boat on .

the next day the battery was dead, and as I had left the boat turned on so long were the logs of the previous day and the worst thing is that my steering servo did not work, I started the engine and the battery quickly took charge, but the servo just as fast moves of push and pull, it moved only less than 1cm, wrote to servocity because I suspect that the driver was unconfigured.

I have dared to create this thread because I hope to receive help from the community, someone knows if it is possible to reconfigure this servo.

or is it better to buy a new one? (They are not very cheap) and I think they are very delicate.

It will be that I can find a servo ready to use, more robust.

will it be better to make a customized servo?

the reliability of all the components is important since it is a big boat, and although I use it on a very lonely beach, I would not like to lose my boat.

thanks for your help.

2 Likes
(rmackay9) #2

OK, sounds like a better servo is the best choice. I think there are very powerful servos on the market so if it were me I would just buy one rather than trying to make a custom servo. I don’t think many commercial servos can be configured except for very expensive ones like those from Robotis.

1 Like
(Canterobb) #3

hello, I am very happy to have an answer, thanks for the suggestion, I have communicated with the servocity team and they tell me that my case is very strange and that this type of servo is very reliable, so I am going to risk it and I will buy new the same 8 "Stroke: 25 lbs. Thrust Linear Servo, since before it worked well and there is already a job done in the boat I developed a system that adapts very well to teleflex.

(Kenny Trussell) #4

Just a small suggestion: if you connect the servo directly to a channel on the RC receiver, does it behave the same way? Trying this will rule out any possibility of the problem being some kind of configuration issue or other problem in the pixhawk.

(Canterobb) #5

thanks for the suggestion, but unfortunately this already tried, even probe with a servo tester but it does not work, I opened the servo and I realized that control card heats up a lot, I also realized that it has a USB port and that if I connect it to the PC and recognize it as a serial port.

I accept more servo suggestions that I can use, they should be strong enough to be able to easily move a Yamaha outboard motor of 6hp and if it is waterproof better.

Thanks

(Kenny Trussell) #6

My friend Dave, @metalsman, is using these on a lawn mower: https://gearwurx.com/product-category/servos/. They seem pretty massive but expensive.

(John Easton) #7

I use a wiper motor, but will be changing over to a stepper motor someday soon.

Any more photos of the boat?

Sounds like a very exciting project.

(Canterobb) #8

thanks for the suggestion, I was very interesting and the value is similar to the servocity servo linear I currently use, just yesterday I asked for one equal to the one that hurt me, since as I have dedicated time and money making adaptations for this to work servo, I am forced to continue using it, I hope this time it does not fail.

1 Like
(Canterobb) #9

hello john makes me very happy that you are interested in this thread, this project started thanks to you, I will gladly upload photos later

Thanks

1 Like
(Canterobb) #10

I finally got the servo, I had no problems installing it, everything worked very well in manual mode, it hurts I can not upload videos to the forum, but it looks great in the water

After trying everything in manual mode, I tried to navigate in auto mode with a very simple mission, but there were problems.

I tried to use the values ​​that John_Easton used in his boat and I improve a lot, sometimes I sail in an acceptable way, but sometimes I surf very badly.

I’m using a radiolink pixhawk, and many times the error message came out of the compass.

I realized that when this message came out it was worse that it worked.

What driver can I buy that is more reliable?

(Canterobb) #11

hello, today I finally got my pixhawk 2.1 cube black, I have never worked with one of these, and I could not make the gps work, I see that it can be connected in the traditional way with the 6-wire gps + i2c, with the 8-wire gps and by canbus, but I’m not sure if ardurover supports this option, or if it’s only available for arduplane or arducopter.

for my project what is the best way to connect the gps?

Thank you

(Tony Atma) #12

Hello @canterobb, I am interested with this project, may I ask very basic question about your steering control.? My understanding is that you use strong servo to move the Yamaha engine left/right, is this correct? Is it possible to use a flap, a kind of “Rudder” (on the plane) that can move left/right for steering control? You said it was good in manual control, bad in Auto is no so good. Did you adjust the PID setting manually to improve the steering control? Is it possible to do Autotune mode to set PID? Best regards,

(Canterobb) #13

hello thanks for the interest, you are correct, I use a linear servo, connected to a teleflex cable, this has been a good solution for me and the manual handling is really good.

in auto mode if I had some problems, I think that is because my pixhawk was not of good quality and there was a lot of noise in the sensors, mainly in the compass, this caused my boat could not keep the course correctly, in this I’m trying to make work my pixhawk 2.1 cube black.

but I could not make the cube recognize the gps here2, it came from the factory with the canbus cable, and I changed it to the 8-wire cable, also changed the gps mode from cambus to ic2 by moving the switch that is inside the gps. but now I do not know what else to do.

(Tony Atma) #14

I have been using 5 (five) Radiolink Pixhawk + Radiolink Gps without any problem at all. But may be your Radiolink Px has sensor problem. I suggest you to do either to change with new Pixhawk 1 (Holybro or new Radiolink with new gps), Or to change the Here Gps with new one. You better use Aluminium foil (about 0.4mm thick) around the Gps as shielding from noise.
Good luck…

1 Like
(John Easton) #15

canterobb, to date there is still no solution to the steering issue using Mission Planner. :frowning:

(Canterobb) #16

Hi, thanks for maintaining interest in my project, I have not had much progress lately, because I bought a pixhawk cube to solve the problem of variation in the compass, but the new GPS here2 that arrived had problems, and I had to buy it again Fortunately the second time I get GPS here2 in perfect condition and now my pixhwak cube is ready to mount it and do tests, I hope this week to tell you how it went.

(Canterobb) #17

Hello, I have news, finally after solving the problem of GPS here2 with my new Pixhawk 2.1 I could try my boat in the water.

In manual mode it worked perfectly, with this I rule out failures in the design of the hull, failures in the engine or in the steering system.

in manual mode running the firware rover 3.5.1 with the factory settings it worked very badly.

Then I configured it with the values ​​used in the John_Easton boat and my boat worked much better. I can’t say everything was excellent but it was much better.

As the idea of ​​this project is to have fun, experiment and learn I will upload the logs of these tests to receive advice on how I can improve the operation.

The modified values ​​were as follows.

ATC_SPEED_FILT 1
ATC_SPEED_P 0.02
ATC_SPEED_I 0.05
TURN_MAX_G 0.2
NAVL1_PERIOD 8
NAVL1_XTRACK_I 0.02
ATC_STR_RAT_FILT 5
ATC_STR_RAT_P 1
ATC_STR_RAT_I 0,05
ATC_STR_IMAX 0.015
GPS_TYPE 2
ATC_STR_RAT_FF 0.8
CRUISE_THROTTLE 80
ATC_ACCEL_MAX 1
CRUISE_SPEED 3
SPEED_TURN_GAIN 10
WP_OVERSHOOT 9
WP_SPEED 5
MOT_VEC_THR_BASE 25
NAVL1_DAMPING

LOGS
https://www.dropbox.com/s/vzy1prb99b3a151/00000034.BIN?dl=0

https://www.dropbox.com/s/m7v85ftdp085nj1/00000035.BIN?dl=0

https://www.dropbox.com/s/66o1dr83vrmp13u/00000036.BIN?dl=0