ArduBOAT will not travel to waypoint

Hi Allecsxx.
Thanks for your interest. Unfortunately, time has not allowed me to “play.” I tried to draw an “electrical scheme” of the components used and their connection. I tested the filter and had the problems described above. after dropping out of the filter, the problems were reduced to the non-alignment of a straight line to points (the behavior you described in the 4-point image). I do not know how, all the defects related to the reduction of the engine speed and stopping it on the go, have disappeared. I can not say that the problem is resolved and I’m afraid the defect will come back in the future. I will test the boat soon, when time and weather will allow me, and I will come back with details. now is winter again in my country ;))
Thanks again and sorry for my English. I use Google translate.

Hi Marius.

You’re using a wrong capacitor. It must be 100nF not 100uF. Use ceramic capacitor with “104” number written on it.

Its not a good approach to feed 5v from your UBEC so many times on the APM. Feed 5v to your devices direct from the UBEC and leave the POWER Module the only 5v power supply for the APM board. After that make sure you do a common ground between all your UBECs and APM.

If the speed reduction had dissaperead I think is all because you changed some parameters. Don’t remember exactly which one, since i’m not using APM anymore. Save those parameters and do a default reset on them and check if the problems are coming back again.

Also connect the motor ESC directly to the battery. I’ve had huge problems when I was using the PM output

Hello! all the above problems have been solved by replacing the brush engine with a brushless one. all autopilot functions work correctly, only at low speed tends to go like a snake. I can find where this small problem is solved. alex_alexs, thanks for your help.

I followed your advice and related to the supply of electrical components. all is okay. Thank you all.