Servers by jDrones

ArduBOAT will not travel to waypoint


(Allecsxx) #1

HI,

Rover 3.1.2 firmware installed via MP.
APM 2.8
WIRING :

RC RECEIVER ------------------------------------- APM INPUT ------------------------------------------ APM OUTPUT
1 1 1 to RUDDER
2 3 3 to ESC

1 REVERSED PITCH REVERSED ?
2 REVERSED THROTTLE REVERSED ?

To reverse them in mission planner as well was an advice by Grant in a post on this forum.

gps HDOP: 0.97 sometimes 1.1 but always around this value.
satcount : 8 never less
gpsstatus: 4

All it does when set on water is spining arround going crazy to random directions.

I’m using default settings for parameters. I have only changed AHRS_ORIENTATION to 8 because my board is upside down. I done all Radio calibration, Compas calibration, Level APM, ACCEL calibration.

I’m going mental with this APM …I had tremendous issues with it .
ARDUBOAT.param (4.5 KB)


(Allecsxx) #2

I Forgot to say that the waypoint in the video was on the right hand side of the boat. I tried to uncheck reverse option in mission planner and all things like this … never seen the rudder to go to right


(Allecsxx) #3

It is something from steer2srv parameters. In steering mode the rudder works but very different … not turning to max right and not going to neutral when joystick is in neutral. … i can’t get my head arround to fix this …


(Allecsxx) #4

RIGHT… since nobody has any answear i done the following things.

  1. DISMANTLE the fucking APM 2.8 ready to go to bin.
  2. Uninstall MISSION PLANNER for good!

reasons:

APM 2.8 / 2.6 are useless!

HOW can anybody explain this :

ESC connected stright to the RC receiver makes the motor to be very powerful
ESC connected to throtlle output in manual mode makes the motor to be weak like a slug a finger on the shaft and motor stops!! (using separate BEC for + -, only signal wire goes to output)

In AUTO mode no matter what i’m doing with the parameters … ( i have 2 days trying to make it work)

When installing Rover firmware 3.1.2 you will install rover 2.5.1 beta … ■■■■ THAT… version full of bugs

Nobody has a clue … even the developers … try that try that etc… nothing works … apm piece of shit


(gmorph) #5

We are all volunteers here and have busy lives. I’m sorry you haven’t been able to configure your system but there is no reason to fly off the handle if we haven’t gotten back to you within 2 days. You are not the only person requiring help.

Attach a log file of when the issue occurs and I might have a look at it.

Thanks, Grant.


(Allecsxx) #6

i can’t download any log files ,
i’m using apm 2.8
rover 2.5.0 beta

mission planner 1.3.50

when i try to download data apm will disconnect and to be able to connect back to it i have to unplug the power.

sorry for my attitude but i arrived to a point where i spend so much money and time to build a toy to play maybe 1 hour and after that just put it away and do something else but until i will put it away i can’t make it work… the whole reason why i’m so frustrated is because to order another board an upgrade like px4 it will take again a full month to arrive from aliexp and i’m just going mental. Why i haven’t done this from the beggining? stupid i’m

After throwing the apm to bin … i took it back reassembled it again and sterted measuring bit by bit all signals etc. What i successfully done is to make the boat travel to the waypoints but in a very bad behavior … it goes in half circles on it’s way to the waypoint. I attached a photo simulating apm’s behavior.

The other thing that really makes me mad worst than i ever thought i can get … is that the ESC get’s some crap signal only when the boat is on water and only when the esc is connected to OUTPUT APM (3 used for throttle).ESC connected to RC receiver works perfectly, never stops. Crap signal means that the boat stops after throttle gets above 1700 PWM. This behavior on water is like this … boat travels one meter after that stops. If i take the boat out from water and put it on the ground and set throttle above 1700 PWM nothing is wrong. You will say that the motor is not powerfull enough to drive in water but believe me that above 1700 PWM and even arround this value i can’t stop the motor with my hand on the shaft, and if i manage to stop it pressing hard, the motor still tries to get forward, thing that on water is not happening , on water i have to bring stick to neutral position and move it up again. I’ve seen some videos on youtube … people experiencing ESC not sync and the issue was because ground cable from signal connector wasn’t connected to ground APM. I done this and still same issue. All i can think about is that the ESC gets some crap PWM while the boat is on water and because with apm 2.8, rover 2.5.0 can’t do any esc calibration … i think the apm will go again to bin… Apologies but is just going forward backward with the apm 2.8 to bin :)))

First suggestion came from TCIII user who said that the esc 12v + - should not come out from TO ESC pin from 3DR power module. Followed his suggestion and connected ESC 12v + - to Battery. Nothing changed

If you have any suggestions please let me know !


(Allecsxx) #7

Update:

Esc problem sorted out. Added RC low pass filter 470nf , R470 to output 3 throttle . I can’t see today if the pwm looks better or worst on the osciloscope but i will test it tomorrow and update will be posted. Anyway … rc filter sorted out the mistery.

Now i have to see what adjustments my apm need to travel to the waypoints without doing circles!

Anyone with some suggestions?


(Khancyr) #8

In case of circle, normally if you don’t have other error (compas etc) you just have to reverse the roll channel !


(Alex Alexs) #9

I think it is reversed so should i uncheck the box ? :)) will try tommorow


(gmorph) #10

Glad you got it working. Let us know how you go with the reverse setting. I’d just test ticked and unticked and see what worked.

Thanks, Grant.


(marius) #11

Hello all!
Allecsxx,
can you please tell me how did you solve the apm problems?
can you put a schematic with the filter used by you and how do they bind on the esc harness
I have the same problems with ESC and steer sevo.
I use APM 2.8
sorry for my English. google translate
thank you


(Alex Alexs) #12

Hi there.


(marius) #13

Hi all!
alex, please tell me the resistance is put on the signal wire and the capacitor is placed between the same signal wire and the minus thread of the ESC?
The filter must only be placed on channel 3 or each channel used on the output
I’m sorry if I ask questions but I’m not an electronics expert, I’m a beginner.
thank you!


(Alex Alexs) #14

Yes. You’re right. The resistance must be in series with the signal(PWM) wire coming out from APM output3 going to ESC. (Depend on your application can go to whatever pin you want as long as an ESC is connected there). Work for servos aswell but is not necessary. One leg of the capacitor must be connected after or before resistance (wherever you want) and the other leg to minus wherever you want, either to battery , APM minus , esc minus. (Much easier to esc minus). This will make your motor spin nice and round without any glitches or breaks and stuff like that. As a better example … Your car drives on petrol … If you put a bit of water on the fuel tank your motor will run very bad with a lot of glitches and so on. This filter will separate the water from petrol and will allow only petrol to go to your motor. (This is just an example for you to understand the use of this filter.)

For your boat going in circles you have to play with the parameters(i forgot exactly what I done). Have a look on my post on thus forum i think there are a lot infos for this…


(marius) #15

Hi all!
Thanks a lot, Alex_Alexs.
I appreciate the help and I will experiment as soon as I buy the necessary pieces. at the moment is still a holiday :slight_smile:
I come back with details of how the ‘work’ is going on. sorry for english, i use google translate.
thanks once again for your help.


(marius) #16

Hi all!
come back with info about arduboat, this time more serious :))

I made a filter, as you told me and I have the same problem. Even now, the engine stops for half a second (and on land, not just on the water), then it continues at rpm before.
The filter was made from a 100nf / 50v capacitor (mounted on the pwm wire and the minus wire at the output ch3) and a 220ohm resistor (mounted on the pwm ch3 thread). The ‘+’ lead on the ch3 output is still used for ESC power (without it, ESC does not work).

Another problem that has now arisen is that the APM stops for a very short time, after a few minutes of operation (dry landing test), telemetry can not be reconnected and the engine starts back at a very low speed. The failsafe function is disabled.

I mention that I use a brush engine. I intend to use a brushless motor to see if there is any difference.
Also, a steering servo, behaves exactly as in the video above.
if anyone has problems like this, please tell me how he solved it.

You can recommend, no offence, to start working in another field :))

thank you very much!


(Allecsxx) #17

Can you draw a schematic of how you wired RECEIVER to APM and APM to ESC including filter?


(Allecsxx) #18

Also upload motor model number and esc . Have you measured the peak current of that motor and compare to esc amp rating? Use a multimeter on amps in serial with the motor. Connect minus from a battery to the motor , one probe of the multimeter to + of motor and the other probe to + of battery. Note the curent draw and check with esc specification.


(Allecsxx) #19

Another advice is to install esc as far as posible from the motor, also if posible wrap the ESC on aluminium foil. Make sure none of the esc electronics are touching the foil. If the esc has electronic components exposed wrap the esc into a plastic foil first and after that into aluminium foil. Connext the aluminium foil to ground. Doing this will probably protect esc from motor noise but it will dramatically lower the amp rating of the esc as the esc will heat up and will not be able to cool down. I will suggest to use and esc with amp rating twice the amount of motor amp rating.


(Allecsxx) #20

Also reading your last post … you can’t power up the esc from + ch3 amp output. This will definitely destroy the apm or blow the fuse. You have 5 leads on the esc. One lead has pwm input + and ground which you can connect it to ch3 output. The other 2 leads are 12v+ and - going to the battery , and finally last 2 leads going to motor.