Servers by jDrones

Arduboat ROS setup


(Kg Fairbarn) #1

I am setting up an Arduboat with a PixHawk running version 3.0.1 and ROS. We have ROS setup on an onboard computer with an FTDI serial USB adapter connected to Telem2. Telem2 parameter is setup for MavLink1 with a baud rate of 57600 and have the a switch on the RC receiver setup for “Guided” mode.

We can see binary (garbled) data when I open a serial terminal so I believe data is being transmitted out of Telem2 and ROS indicates the serial port is open.

Can anyone point me toward a tutorial or more information on how to setup the parameters for offboard control?


(Khancyr) #2

Hello,

Guided mode is what you are looking for ! http://ardupilot.org/rover/docs/guided-mode.html


(rmackay9) #3

KG,

I highly recommend upgrading to Rover-3.4. 3.0.1 is really old. I don’t really think it’s going to work well and personally at least, I can’t provide support for a version this old.


(Kg Fairbarn) #4

I don’t think the issue was in the APM version but rather a bad serial connector (I wired my own that connects to an FTDI Serial-USB adapter). I connected my windows onboard computer directly to the PixHawk that is running Mission Planner and used the Telem1 915 mhz wireless serial link to connect the Linux Computer running ROS and it seems to work OK now.

I upgraded to 3.4.0 and am now not able to switch between manual/guided/auto modes without a valid GPS fix. Is there a way to turn off the valid GPS check so that I can switch modes while developing indoors?


(rmackay9) #5

KG,

OK, sounds like progress!

Setting ARMING_CHECK = 0 to turn off the arming checks but the vehicle still won’t move (at least it shouldn’t) in the autonomous modes without a GPS (or wheel encoders).

When the vehicle is disarmed it should always be possible to change modes, it’s once it comes time to arm the vehicle that it won’t change. Older versions of Rover didn’t support arming, the latest ones do and there’s an ARMING_REQUIRED parameter that specifies whether arming is used or not. I personal set ARMING_REQUIRED = 1 and then use a channel 7 auxiliar switch to arm/disarm.


(Kg Fairbarn) #6

rmackay9, thanks for the help. I set ARMING_REQUIRED = 1 but cannot figure out how to map an aux switch for arm/disarm. It is not in the available options on the pulldown list when mapping aux switches. I can arm with the throttle hard over to the right but can only disarm with the GUI.

Is this a copter/plane feature but not a Rover feature?


(rmackay9) #7

KG,

My guess is that the version of mission planner might be old (assuming you’re using MP and not another GCS) or more precisely it’s parameter information is out of date. The magic way to update the MP’s parameter description info is to go to the Flight Data screen, press Ctrl F, push the “Param gen” button, wait about 2 minutes and restart the MP.

The wiki for the auxiliary switch setup is here but you’ve probably already seen it. It is possible to more directly update the CH7_OPTION parameter to “3” from the full parameter list.


(Kg Fairbarn) #8

Thanks rmackay9, I did not see the Ch7 option under config>basic tuning, I assumed all channel mapping was done on the intit setup>servo output menu.

Can another aux channel be added. Thinking it would be nice to have another 3 position toggle switch to go between other modes. I have one 3 pos toggle setup for manual/guided/auto and ch7 setup for arm/disarm. Would be nice to set another 3 position toggle for loiter/RTH/nothing.


(David Boulanger) #9

Can you mix the two toggles together in your transmitter and put them on the same channel? This is the way most get 6 modes out of the transmitter.


(rmackay9) #10

KG,

Yes, multiple auxiliary channels are high on the to-do list. Peter Barker has a PR that does this already it’s just that it’s part of a very big change to how we do mapping of input channels so it hasn’t made it into master yet. It will though.


(Kg Fairbarn) #11

I have channels to spare but there is currently no ArduRover support for using more than one aux channel. It’s not an issue as long as you are connected to mission planner.


(David Boulanger) #12

all I was saying is I have 6 modes of operation with a two position switch and a three position switch mixed and linked to the same channel. Mission planner is not needed to be connected. Maybe I’m not understanding the ROS setup.


(rmackay9) #13

I think KG wants more auxiliary function switches rather than the flight mode switch…