Servers by jDrones

Apsync/tx2 beta


(Randy Bachtell) #1

@peterbarker Peter, what jet pack needs to be used to flash apsync tx2?

Thanks, Randy


(peterbarker) #2

3.2, assuming you’re talking the image up on the server.

I think Nick did get this flashed - but he had to use the raw image not
the sparse one.

Peter


(Randy Bachtell) #3

Thanks Peter, could you direct me to Nick? I am unable to flash the image to the tx2. Tried to use the TX1 command line in the wiki modified to tx2 with no success and don’t know where to turn.

Cheers, RB


(Nick) #4

Hello rbachtell, here’s a step-by-step guide for flashing a custom image to the TX2:

These instructions assume you have the latest version of Jetpack installed on the host machine.

Download full APSync TX2 image here: (25GB!)
http://firmware.ardupilot.org/Companion/apsync/beta/apsync-tx2-201804270923.img.raw.xz

Copy new full image over the sparse system.img automatically created by Jetpack during initial setup:

Copy apsync.img.raw to the hosts /bootloader/system.img directory with the following command:
sudo cp apsync.img.raw bootloader/system.img

  • Put the TX2 into bootloader mode by holding the “Force Recovery” button (aka “REC”), then press the “Reset” button (aka “RST”) and then release the “Force Recovery” button
  • Check the TX2 is in bootloader mode by typing “lsusb” on the host machine and look for “NVidia Corp”.

Flash the clone image to the APP partition with the following command:
sudo ./flash.sh -r -k APP jetson-tx2 mmcblk0p1

TX2 should boot when complete

On start-up an access point is created with name “ardupilot”, password “ardupilot”.

A light weight webserver runs on the companion computer (using CherryPy). You can connect using (http://10.0.1.128:8000) to change configuration information including:

  • Wifi access point name and password
  • List of trusted wifi access points
  • List of log file directories and web server url (i.e. upload target)

Note: If you are using the complete TX2 Dev board you must change the following config files which remaps the serial connection to the J17 header.

Under apsync user, modify:

to:
Device = /dev/ttyTHS2

and modify:

to:
port=/dev/ttyTHS2

Save & Reboot


(Randy Bachtell) #5

Thank you Nick, that worked just fine and explained several things I have been unsure of. Always a learning experience😎

Cheers, Randy


(Nick) #6

Perfect!

Happy to help!


(Randy Bachtell) #7

Nick, I guess I was asleep when I looked at the results, all I have is an ardupilot hot spot. Everything looked like it was working for the flash but I don’t have any apsync files on the TX2. I’m going to try a few things and I’ll let you know.


(Nick) #8

Make sure you are under the correct user. (apsync, not nvidia) If you’re seeing the AP, the files should be there.


(Randy Bachtell) #9

You guessed it, in my quest I forgot to change user but all is not well. I can’t get mavlink communication. What board are you using? It looks like the J120 bsp is not included in the tx2 image. USB, serial port and fan not functioning on the j120. I went back to the development board, changed the two conf. files but still no mavlink. I have been using the TX1 version on both boards since it was released so am pretty familiar with the system (except for user😎). Let me know if you have any ideas.

Cheers, RB


(Randy Bachtell) #10

Got it running on the dev board. baud rate change to 1500
Also now have mavlink on J120 but no USB, system is useable now, Thanks for your help.

RB