Servers by jDrones

APSync for Jetpack 4.4

I just updated the scripts to support Jetpack 4.4.

Although I tested it only with a TX2, the code should run in theory also with a Jetson Xavier NX. Would be great if someone is willing to test it with a Xavier NX since I don’t own one myself.

@mtbsteve First of all, thank you for time and research in regard of supporting Apsync with the latest release of Jetpack 4.4
Nevertheless, there are some questions about connectivity of pixhawk cube with jetson.
Describe my situation:
I’ve got a AION Robotics R1 rover with Jetson TX2 Dev. kit pixhawk cube 2.1 on board.
Pixhawk flashed with the 4.1 Dev ardurover firmware.
serial1_baud = 921600 (also tried 1500000, but when I’m trying roslaunch apm.launch, it give me an error of invalid argument)
serial1_protocol = mavlink1

Using sdkmanager I flashed the jetson with a Jetpack 4.4 (despite the fact that there is already released version 4.4.1)
Followed your instructions and installed all packages and dependencies.
Set the following setting in config.dev:
export NORMAL_USER=apsync
export TELEM_SERIAL_PORT=/dev/ttyTHS2
export TELEM_SERIAL_BAUD=921600

Pixhawk conected with Jetson, TELEM1 - J17 (I tried using tx-rx, rx-tx, gnd-gnd and also tried tx-rx, rx-tx, rts-cts, cts-rts, gnd-gnd) wires are ok.

The thing is that I cannot get the mavlink message when I’m roslaunch apm.launch file.

Do you any clue what it could be?
One more question what should I do to make WiFi working on client mode rather than AP mode on boot?

Servers by jDrones