Servers by jDrones

Appx321 SDK containing ‘UAP.props’ for ´UAP 10.0.17134.0´ Cannot be located

Hello everybody!

I download mission planner after the first build I got many errors, I corrected them one by one except this error in title above which persists I tried to install sdk windows and change the version of sdk in this file EXTLibs/WindowStore/WindowsStore.was proj but nothing has changed. See the image bellow.

For information when windowsstore is unchecked in batch build the solution compiled
successfully.

Regards,

Finally, I find the solution of this error.
So the SDK for Windows 10 17134 is missing, I need to install it
Go to Get Tools and features from Tools menu or Run Visual Studio 2019 installer ( C:\Program Files (x86)\Microsoft Visual Studio\Installer\vs_installer.exe ), click on modify , and select 17134 SDK under SDK/framework in individual components tab of the installer:1512420

Yeah, but why do you want to build a Windows Store version of Mission Planner ?
Dont do Build ALL, just build the Mission Planner project.

2 Likes

I selected all projects as showed in ardupilot’s doc then rebuild
Thnak you for return @Eosbandi

We’d absolutely appreciate if you tried to follow the wiki instruction/s and had issues, that you might do an update to the wiki … https://ardupilot.org/dev/docs/building-mission-planner.html there is a ‘edit on github’ link, right on the page.

1 Like

its already there, just missed as part of the install at a guess

During the install Process, you will be prompted to install optional “workloads”, at this stage, you must select:

  • “.NET desktop development”
  • ASP.NET and web development”
    *** “Universal Windows Platform development”**
  • “Mobile development with .NET”
  • “.NET Core cross-platform development”
1 Like
Servers by jDrones