APM2.5 Failed to create log - wont log this session

Please help

When I connect a small box comes up that says “Failed to create log - wont log this session”.

I want to start doing mapping and I need the Lat,long and alt from the logs but it doesnt make logs.

Does any one know what could be the problem.

When I try to download DataFlash log via Mavlink it says “Cannot get log list”

I dont know what to do now.


It is in a skywalker plane, flies great every thing works great exept that the apm 2.5 does not capture any logs.

Firm ware is a very ild version.

@Kobus Labuschagne,
What is your LOG_BITMASK parameter set to?


firmware: arduplane v2.78b

@Kobus Labuschagne,
Try 32767.

Still the same problem

I tried multiple bitmask’s and doesnt help.
Then updated the firmware to ArduPlane V3.3.0 but still when I press connect I get the message saying “Failed to create log - wont log this session”

can someone please help

Has it ever created logs?

Do I remember correctly that a little while back there were some clone boards released with some chips missing that meant they couldn’t record log files??

I am not sure, only start needing the logs now.

Got this board straight from 3dr a couple of years ago