APM unresponsive after interrupted FW update

Now i can’t access the copter via usb because of driver issues. Also using the APM with a mac and connected VIA MAV link the dam software is asking me to press the safety switch. I don’t have a safety switch. I really need to be able to connect VIA the usb but can’t.

Any ideas?


Oh and now I have just discovered that my transmitter is not connecting to the APM even though it is bound to the receiver. Really what is going on. Nice sunny day and I was going to go out and fly for a while. Now I will just go and fly my DJI and other plane and leave this brick alone for a while.

[color=#008000]Please refer to the instructions on how to use this forum and add the missing information![/color]

I have an X8 RTF made by 3D robotics. I have only had one very short successful autonomous missing using this copter. Since the last crash I have not flown it using the mission planning software but just simply using the transmitter to arm and fly it either in loter or stabilization mode. Yesterday I got the confidence to try and fly it using the APM software. At the time I have not updated the APM 2.0 software on my Macintosh and was prompted to update the software which I did I was connected to the copter via the MAV link. At this point I lost connection. I then restarted the software and powered up the x8 again. I was able to connect via the MAV link but can not arm it because the software is asking me to press the fail safe button on the copter for which I don’t have. I then tried to connect via the usb cable to see if I could perhaps see what maybe the issue I can not connect I can not get the USB connection to come online ether in windows are the mac. Windows gives me the error that the device is malfunctioning and it dose not recognize the device.
Also the transmitter is no longer working even though I have amber lights on the AR 8000 which I believe indicates that it is bound to the receiver. Now please recognize that everything was flying and working okay prior to me clicking on the update to the latest APM software I have not changed the firmware on the APM and can not plug in directly via the usb.
Not sure what to check at this point so any ideas would be appreciated.


I still can’t make sense of what you are referring to. You are talking about different APM softwares.
Can you specify WHAT software you are talking about when?

  • APM-Planner, which is a variant of groundstation software
  • APM:Copter which is the software which is running on the flightcontroller itself

MAVLink is a protocol and is used through telemetry radios, bluetooth and the USB connection. What do you mean with “connecting via the MAVLink”?

Which flightcontroller are you using?
And what exactly is your problem or question?

A title like “Everything was okay until the update” doesn’t tell anything…

Please forgive me for not knowing the correct terms. Sorry to create such confusion from my lack of knowledge.

I thought and must be incorrect that the MAV link is the 3DR radio that connects via a usb cable to a computer then communicates with the radio on the copter itself. That is what I am referring to. So What I mean is I can connect to the X8 RTF copter via a direct plug into the AMP unit located on the X8 using APM Planner version 2.0.9 which was what I upgraded to. I can also can’t connect using the same method using Mission Planner v1.3.1 for windows. The other issue is that I have a Spectrum DX7 transmitter and it no longer works. Meaning that if I go into the APM v2.0.9 and look under Initial setup and try and calibrate the transmitter it is not seen by the software even though I have amber lights on the AR8000 receiver indicating that it is bound to the transmitter. Again things were ok and working prior to updating to APM planner 2.0.9 for my mac.
Thanks for your patients

Yeah, I know, the terminology is confusing. Way too much “APM” everywhere :smiley:.

Ok, let’s see if I understood you right:

  • Your X8 has an Ardupilot Mega flightcontroller
  • You did a software update of APM-Planner, the ground control software
  • After the update you CAN connect via telemetry radio but you CANNOT connect via a direct USB cable from the computer to the controller
  • You also CANNOT connect via USB from another computer using Mission Planner for Windows
  • Additionally, since the update your remote control doesn’t work anymore

If I got that all right… Next question would be: Are you sure that you only updated the APM-Planner software? I’m asking because the fact that the R/C doesn’t work anymore and you also can’t connect via another computer let’s me think that you maybe also tried to update the controller’s firmware and that went somehow wrong.

Yes you have the questions corret. Okay so this could be the issue. Because I did want to do the firmware update so I plugged in the cable to the mac I was then interrupted before i was able to. So yes something went wrong. So I am guessing that the flight system has a way that I can reset it and try the update again then load my old prams into the apm. Do you know how?


Now as I figured out what your problem is, I can move your request to the right subforum :slight_smile:. I’m sure, some supporter will take this shortly.

So where did you move the post to?


WOW thanks for the overwhelming response. After a while I decided that the APM had a problem so I contacted 3D Robotics. I must say that they honored a warranty claim on the APM and sent me a new one. The copter has been flying perfect since. But then I noticed a funny reading of voltage so I when looking for a problem. I found that the PPX board had shorted and had melted the ground wire. This might have cause the failure of the APM and the issues. Well I have replaced the board and all is well.