APM:Rover 2.47 Released

The ardupilot development team is proud to announce the release of
version 2.47 of APM:Rover. This is a minor bug fix release. The most
important change in this release is the fixing of the skid steering
support but there have been a number of fixes in other areas as well.

Full changes list for this release:


  • add support for controlling safety switch on Pixhawk from ground station
  • prevent reports of failed AHRS during initialisation
  • fixed skid steering that was broken in the last release
  • report gyro unhealthy if gyro calibration failed
  • fixed dual sonar support in CLI sonar test
  • fixed Nuttx crash on Pixhawk with bad I2C cables
  • added GPS_SBAS_MODE parameter - turns on/off satellite based augemtation system for GPS
  • added GPS_MIN_ELEV parameter - specifiy the elevation mask for GPS satellites
  • added RELAY_DEFAULT parameter to control default of relay on startup
  • fixed bug in FRAM storage on Pixhawk that could cause parameters changes not to be saved
  • better handling of compass errors in the EKF (Extended Kalman Filter)
  • improved support for linux based autopilots
  • added support for PulsedLight LIDAR as a range finder

Many thanks to everyone who contributed to this release, especially
Tom Coyle and Linus Penzlien for their excellent testing and feedback.

Happy driving!

This week I got my second Pixhawk, uBlox and 3D Radio kit for my rover. I installed ArduRover v2.47 firmware but there was a very strange behaviour of the compass in the Mission Planner Flight Data screen.
My first thought was a bad uBlox so I exchanged the units, no change. After a lot of variable changes I installed the ArduCopter V3.2.1-rc1 Octa, the same as I use for my huge Octocopter. Then everything was fine, the compass too. Now I started to think the firmware installation had gone wrong so I reinstalled ArduRover v2.47 with the same result as in the beginning.
My rover stands perfectly still indoors, close to a windows, but at the navigation screen it looks as if I’m flying aerobics.

Please help

I have alerted our Developer/Programmer Gant Morphett to your issue.

If I want to test the “latest” is Px4 folder the right choice for Pixhawk?


This is the correct “latest” firmware for the Pixhawk (not PX4): APMrover2-v2.px4 in the PX4 folder.

GPS not switching over.
I use the Piksi as main GPS and the uBlox as the second. Both can be seen in the MP Status.
When the Piksi hangs, and it currently does quite often, GPS status becomes 0 but Mp reports “No GPS” althougt uBlox is working and the status is 3.
GPS_AUTO_SWITCH is set to 1 (Enable)

I run the latest version, released 2015-03-04.


I see a similar thing when I do this in SITL. MP will have the status “GPS:No GPS” when I disable the first GPS however the rover still drives fine. If you have a look on the Status tab in MP you should see that the second GPS is functioning fine and gpsstatus2, gpshdp2 and satcount2 are all ok. You should also see all the first GPS varibles as 0 or whatever failure it is coming from the Piksi.
Basically the autopilot on the rover is ok and the rover will drive fine but the Groundstation’s can’t display it correctly. MAVProxy has the same issue and so does APMPlanner2.
Its on the TODO list to be fixed - be great if someone took that on.
Thanks, Grant.

Found the existing issue for it on MissionPlanner github.


Thanks, Grant

Thanks for this info.
The “white powder” on the ground prevents me from live tests by now so I test as much as I can indoors.
I didn’t realize it would be MP problem but if the rover continues to run, as you wrote, it must be.

When the Pixhawk and Piksi will be able to use RTK I will be more than happy as I’m running a project based on this.