APM heli analog tail servo moving real slow, Help Please

Thanks in advance for any Help
APM 3.1, arducopter ver 3.2.1, Mission Planner software, Emax ES08MA analog servos on collective and tail rotor, 450 Heli with flybar experiment, no expo on rudder in transmitter?
RCSpeed is set to 50 for analog servos, all servos are powered by UBEC 5 vt, 5 amp power, APM is powered by another UBEC, Problem is the 3 collective servos travel fairly quickly up and down, move good for analog, the tail is moving very slowly, barely moving, receiving same power as the collective servos, but moving soooo slow it cannot hold tail? Tried swapping servos, no difference, seems tail servo is not getting a strong signal?
If I try to increase Rate P or FF even a small amount then I get all kinds of tail wag, have tried moving position on servo arm, not much change?
Any suggestions for a fix for this problem?

You know its not the servo if changing rates make it wag. Whats your headspeed?

Not sure of headspeed, no way to measure? Just trying to setup, but I would say I am at lease 1/2 throttle, heli is attached to a small wooden lazy susan ( to check if yaw is holding) and headspeed is great enough that copter is trying to lift lazy susan and all off the carpet. The distinct slower movement of the tail servo is definitively noticeable compared to collective servos?

Loaded rover firmware, reloaded copter 3.2.1, everything working as it should, Thanks for help