APM crashed ignoring pilot input and had weird data logged

I have set-up arduplane on a HKPilot 2.5 (3.0.1 firmware) and loaded the recommended parameters for my Bixler. I took off and went into a bank towards the right to turn. Shortly after this it started spinning slowly and went straight into the ground - ignoring the pilots inputs. (it was completely destroyed) [Problem Solved - Lost telemetry signal and went into failsafe but RTL wasn’t setup properly] - Picture 1

Second time, it does a similar thing but because for some reason the tx or rx outputs a signal to change the mode to FBTWA and then back to manual 2 seconds after. I recovered this (once it went back into manual) and literally scraped the ground as seen in picture 2!!

I took it up a third time, this time really close to me and low to the ground, low and behold the same thing happened but this time it continued doing what it was doing, went straight and hit the ground straight. (like a very rough landing at way to much speed) Looking at the logs, all of a sudden ground speed drops to 0 but I can see it moving on the map. Another weird thing is roughly the moment of impact according to the logs it veers off to its left and into the rubbish tip, which didn’t happen!

I don’t know what to do and at this stage the servos and esc are plugged straight into my receiver but the autopilot is still there so I can get live (and logged) telemetry. I have solved crash 1 and 2 (just need to find out why tx or rx sent mode change signal) but need help with diagnosing crash 3. I have attached all log files, links for pictures below. (flight 3 starts at the time of approximately 10:57:32)

Moving everything around
Rebuilding destroyed plane :laughing:

Picture 1
Picture 2

Thanks heaps!

Is there any chance that it could be a faulty board? I forgot to mention that I cannot configure the air telemetry radio, only the local one and sometimes it doesn’t work at all. Someone at my local air club (who is into electronics) said that it may be a faulty board which makes sense.

[color=#00BF00]I will leave this here until it’s clear if it’s a software or hardware issue. If it’s a hardware issue, I will close the topic and you will have to contact Hobby King for support.[/color]

Regarding the telemetry radios; Unless you have already, upgrade mission planner to 1.3.1.
A bug in 1.3.0 prevented changing settings on the air module.

if you can - post .log from APM, tlogs does not help a lot.