APM 2.8 Bricked

HI guys, hope you are doing well!

I have a problem with 2 APM 2.8, I think they’re bricked, both APM do not connect to mission planer and also i can’t download any firmware!

Rading and watching videos I buyed an usbasp to unbrick my APM’s but i didn’t worked. Can’t find a solution :frowning: please what can I do? :frowning:

Hi Aaron.

  • APM aren’t supported anymore.
  • I do have three or four in a drawer somewhere.

If I can suggest, perhaps get yourself a Pixhawk clone 2.4.6 (with 2Mb of memory). They are economical and work a treat.


I know this may sound silly…but have you tried more than one USB cable? I have had issues in the past with cables that worked fine for a while and then just didn’t work. Sometimes they will connect and show up in device manager but not communicate.

Also, the above post is correct. Get your self a Pixhawk. I moved from the apm to Pixhawk. I have a radiolink. They are a much better FC, have a better processor and can compute faster and have much more headroom than an apm running at almost full capacity all the time.

Throw them away. A $30 F4 nano board will run circles around those old APM’s.