APM 2.5 Telemetry

I have a problem with connecting my telemetry to an APM 2.5. The problem is the same whether I use my Xbees or 3DR radio.

I run the same pair of Xbees on my 'copters and Plane and have no problems getting telemetry into the mission planner from my PixHawk on an Octocopter and with earlier APM hardware so the Xbees are working.

I have recently upgraded to an APM 2.5 and loaded Arduplane 2.77.

I get no telemetry using the same Xbee hardware that works on my other APM gear. I have checked the wiring, the COM port is correct, a loopback test works, the 5v line is at 4.9v, I have reinstalled mission planner and Arduplane, and set the system up from scratch. I have also tried a pair of 3DR radios but exactly the same. I can see a datastream coming out of the APM with a scope and data is being transmitted from the mission planner and being received but no link is established. If I use a terminal programme (RealTerm) rather than mission planner it will not resolve the data coming from the APM unless I send it random characters when it will return a few pairs of hex characters.

Any suggestions as to how I can debug the problem?

If I switch to UART2 by changing the links under the APM do I have to do anything to get the telemetry data out of the new UART.


After a great deal of testing to find out what is going on I discovered the Xbee interface board used at the aircraft end of the telemetry link was faulty. It was causing the data sent back to be garbled resulting in the link failing. The interface board I was using was a Sparkfun type and I have changed to a DIYDrones interface.

Why the 3DR radio failed as well I am not sure. It started working later.