APM 2.5 running v3.0.1 firmware on DJI F450

Hello All,
I jumped onto the UAV bandwagon about 6 months ago. I got myself a DJI Flame-wheel 450 and was trying out various MultiWii boards. I then got myself a APM 2.5 and installed v2.9.1b a few months back. I got it working for the most part. The Stabilize mode was working all right, but I had some issues getting Loiter to work consistently and RTL would get the Quad back to the point of launch (or close to) about 75% of the time. I used to fly mostly in my backyard. But, there was not much room out there.

Yesterday, I installed v3.0.1, and was able to get everything configured and setup in a few hours. The Mission Planner v1.2.67 has been improved vastly and it’s actually pretty cool to use. Before upgrading the firmware to v3.0.1, I went into the Terminal CLI and erased the EEPROM, just to make sure that no older configs/parameters etc., were lingering around. I then installed the new firmware and went about it step by step.

The only parameters/PIDs I had to change from the defaults were the following:

Roll/Pitch Rate Control P: 0.145
Stabilize Roll/Pitch P: 4.0
RTL_ALT: 0 (so as to maintain current altitude during RTL)

The DJI Flamewheel 450 configuration is standard, with the APM 2.5, UBlox GPS, 3DR Telemetry Radio, Spektrum AR6115e 6ch receiver (using a Dx8 Spektrum transmitter), and Turnigy 3s 11.1v, 35C LiPo batteries. No additional payload on the quad yet.

I took out to an open field and tried it yesterday and it worked real good. The Alt-Hold was very good; the Loiter was pretty stable and RTL worked great. The only point I wanted to make was that, the quad came back to the point of launch and came down to 2m and hovered, but it did not land on its own. It thought it was supposed to, but I probably have to do some more reading to make sure.

I also tried the “Position” Flight-Mode but that was not as stable as the Loiter. But, I tried that just once. Maybe I’ll retry in a few days and provide an update.

This v3.0.1 version of the Arducopter is quite impressive and I would like to thank all of the developers who have put in so much effort and time to create a very cool open-source Autopilot.

I also bought a Naza M Lite about a week ago and set it up on a similar DJI f450 setup. It works great, as advertised. The Alt-Hold and GPS-Position Hold work awesome. But, the main issue is that it lacks telemetry and the ability to tune, and much more.

But, this version of the Arducopter looks very promising and I’m glad that I have it working. Will do a few more test flights as time permits, and post any updates as necessary.

Thanks and happy flying.

Nice of you to share your successful flight. It will help to give confidence to other members here on the website.

Yes, thanks. That was my reasoning too. Hopefully, many other use such a similar setup, and if they do, they can try the PID setting that I have posted, and hopefully it’ll work right away. I spent a few months on v2.9.1b, and doing lots of reading and many trials and errors.

So, yesterday, when I burnt in the v3.0.1, I did program my Dx8 Aux-3 knob for in-flight tuning for the Roll/Pitch rates and Alt-Hold PID rates. After spending some time tuning, I realized that, not much had to be tuned, just two parameters, for a good stable flight.

I will do a few more flights and make sure that everything still works in a predictable manner and post an update.

Again thanks to everyone for some cool programming and getting this ope-source project to the state it is in today.

Hello Folks,
Just wanted to post on update on a few more flying sessions that I had. I went flying, the day before yesterday. The weather was simply awesome, but it was pretty windy. The winds were about 15-20mph. So, I fired up my DJI450 quad anyways, so I can check things out in windy conditions. The Altitude-Hold and Loiter were pretty good. I then tried RTL a few times. It back to the point of launch (within an ~ radius of about 5-10feet), but during one of the RTL attempts, it started to take a different path rather than home. It did not appear to be a hardware issue, but more like it got incorrect GPS signals that took it on a veered off path. I had to switch it immediately to Stabilize and take control, which it did. I’m glad, I did not lose the bird.

Well, today, I went back to the field again. The weather was great and barely windy. I tried the same flight-modes again. As it was not windy today and it behaved very very well :smiley: . The Altitude-Hold was the best. The reliability appears to have improved very well from the previous releases. The Loiter was also very good.

And I tried RTL again 4-5 times, and every single time, it came back to the point of launch, ± a few feet. That’s pretty impressive. I also figured out that if I set the RTL_ALT_FINAL to 0, it automatically lands. I missed reading the documentation properly in the Full-Parameter List earlier in the week. But, I prefer keeping it at the default of 2meters and switch to Altitude-Mode and land it when I need to.

I did try the Position Flight-Mode, several times again. But, there appears to be some issue with it. I had similar issues in my first post, from earlier in the week. I first switch to Altitude mode on my 3-position switch and then move over to the 3rd position, which is for Position-Hold. It appears to start gaining altitude sometimes and when I switch back to Altitude-Mode, it dropped like a brick. And at other times, it appeared to lose altitude (even though I did not touch the throttle-stick), after I had it steady in Altitude-Mode. I tried this multiple times and had a similar behavior. It’s not so much that it starts to pitch or roll and lose position in that fashion, but it appears to have issues with holding its Altitude, in Position-Mode.

I do the same thing to switch back and forth between Altitude and Loiter and it works perfectly and have not seen issues like that.

I don’t see myself using Position-Mode much, as Loiter works pretty well now. Maybe I haven’t understood the true difference between the Loiter and Position-Hold modes. I thought the only difference is that - Position-Mode is Loiter, with throttle control. So, if one does not touch the throttle, after switching to that mode, shouldn’t it hold it’s altitude position too? If someone knows more about this, please reply. I don’t want to be hung up on this, but just wanted to know to get a better understanding.

I also tried the Land-Mode and it works just fine.

Finally, now that I have tried most of the modes that I’d probably like to use, I will probably go ahead and try creating a Mission, download it and see how that goes.

Cheers everyone and Have a good day.

Hi Folks,
I took out my quad today and I had just started my flight, switched to Alt-Hold and Loiter. I landed it and retried it, switched to Loiter and after a few seconds, it just crashed. It fell from about 10feet like a brick.

Can someone please help check the attached log and let me know what might have caused this crash.

Any help is greatly appreciated.