APM 2.5 not responding to my Radio. Please help

I have configured 6 position switch with my er9x and calibrate Radio with APM 2.5 in Mission planer . when i check PWM in it change to 1118 1323 1426 1579 1681 1887 i get these results Radio Calibration option. But when i try to add these number to Flight Moods , where ever switch i changed the Current PWM is : 1499

So i cant set Flight Moods.

2nd thing is in Flight Data Display it Armed Its self and what ever I tried to Disarm I cant Disarm it by Radio or by Mission Planer. when i press Arm/ Disarm i get " Error : Arm Message Rejected by MAV "

Please I wish some help to fix this problem.

Thank you

I know this has been resolved for you, but I am having the exact same, "Flight Data Display it Armed Its self and what ever I tried to Disarm I cant Disarm it by Radio or by Mission Planer. when i press Arm/ Disarm i get " Error : Arm Message Rejected by MAV " " your solution would be greatly appreciated.

On my Pixhawk I have a solid Blue LED (inside, so there is no GPS) and i see no servo movement.
i have my Pixhawk in Manual mode, i can change modes.
i can see the PWM change on the Radio Calibration tab in MP. if plugged directly into my receiver i get servo movement, but still nothing from the Pixhawk Main Outputs.

any help is greatly appreciated. I’ll be scouring the Wiki and Google in the mean time.


Hi Brian,
I have the same problem that you have. I use the PIXHAWK and QGC.

  • receiver is connected to the RC IN of the PIXHAWK via PPM encoder
  • main out channels are connected to the servos
  • I can see the RC stick throws/inputs reflecting on the QGC
  • the solid blue (green when I take it outside) is seen on the PIX
  • PIXHAWK is in the MANUAL mode
  • RC stick throws/input is not changing any of the servos. So basically I cannot get the MANUAL mode to work. RC is not able to control the servos through the PIXHAWK.

Were you able to resolve your problem? Could you please share …thanks…

Hi all,

I have the same issue…
First time using this platform, so not sure if I have missed something completely simple but I did follow a number of setup / startup guides.

Using either mission planner or APM Planner, the result is the same.

Loaded firmware - all ok.
Calibrate radio - responds to inputs all ok.
Calibrate other items, Accel,Baro etc - all ok.

Servos are powered and on power up of hardware, all servos center and remain under position control.

Ensure I am in manual mode and then attempt to move control sticks on radio - no change to servo output. (servos remain under position control though so they are working)
Try other modes - no servo movement (remain centered)

In Mission Planner, if I go to status tab and watch the channel in and channel out data… they do respond as it should and a stick movement corresponds to a channel in change which corresponds to a channel out change, but again the servos stay locked on center.

However… if I go to Servo tab and click LOW, HIGH or TOGGLE the servos DO respond and move accordingly … so the servos can work under the board control…Now I am completely confused.

As per the other posts, I also get an immediate ARM on connection to the MAV and I also when i press Arm/ Disarm i get the " Error : Arm Message Rejected by MAV "

Any help will be appreciated as I have been at this for days!

Thanks for ready,


PS If someone thinks this should be posted under a different section, let me know and I will repost. (As I can get the servos to move via the servo tab.)

Please share with us the solution for this problem because we are having the same error. Thank you in advance.



:cry: :cry: :cry: :cry: :cry: :cry: :cry: no one?