[APM 2.5] Jittering airplane & autopilot offset


I’m trying to figure out what is going wrong.

TX: Futaba TF18MZ
PPM Encoder: Updated to latest
ArduPlane Version: 3.0.1

First, I’m not sure, but I think that the problem lies in using FASSTest Telemetry (I have Futaba’s current/voltage sensor and GPS installed). Because it also transmits the data onto my transmitter, it eats up some portion of the PPM signal (I guess that’s how it works?). The Roll P parameter is set to 0.8 (less than that really causes the input commands to be unresponsive) and I and D to 0 because it says in the manual to first set P. It stabilizes the airplane perfectly if I leave it at for example at an angle of 25° and switch from MANUAL to FBWA. No overshoot, just fast stabilization. That’s fine, but the airplane is exhibiting jerking motions when I input some Roll when I am flying in the FBWA mode. Looks like the airplane is fighting my input OR the Futaba telemetry is causing the autopilot to think that I released my stick for a fraction of the second. If I lower the P below 0.7 it becomes completely unresponsive and just flies straight.

The second thing I’d like to ask is, what is the proper angle notation (+ or -) for the offset. I want the autopilot to hold 2° of pitch during the cruise flight. The wing and the autopilot are both set at 0°.

Providing tlogs and/or data flash logs will greatly enhance troubleshooting your issue.

Oh, ok. Here it is.

Ok so now I tried switching back to an ordinary R617FS and now my throttle doesn’t work. It has a lot of lag. Sometimes it also doesn’t give full power. Do you think it could be ppm encoder or is the esc dead?

I bought another airplane and different ESC and receiver (a basic receiver, no-telemetry), problem solved. Arduplane does not like FASSTest telemetry (FBWA twitching) and the ESC is bad.