APM 2.5.2 and external compass question

I have a 3DR APM 2.5 (I think 2.5.2 based on comparing images) and I’m trying confirm the steps needed to enable an compass. Most of the instructions I’ve read indicate that I need to cut a trace on the board.

However, a multimeter says there is no continuity between the two pads on either side of the trace and there is no evidence that a trace was there and removed (i.e. scratches or a groove) . See the attached pics.

If have have the Compass setting at “APM with OnBoard Compass” and ROTATION_NONE, the onboard compass appears to work. The heading and the compass gauge on the FLIGHT DATA screen show the correct orientation. The Live Calibration on the Initial Setup/Compass doesn’t seem to work though.

With the Compass setting at “APM with External Compass” and ROTATION_ROLL_180, movements of both the on board and external compass affect the FLIGHT_DATA screen. Only movements in external compass affect the Live Calibration.

Can someone give me some advice? Should I gouge away at the spot between the pads? I was thinking that a continuity test would tell me when I’ve “gouged enough”, but not if the starting point is no continuity.


As you have an APM2, COMPASS_EXTERNAL is the parameter you need to set. If you set it to 1 then it will use the external compass. There is no need to cut the trace for the on board compass. You can have both compasses operational and the software will use whichever one is set via COMPASS_EXTERNAL.

Thanks, Grant.

On an APM2.5 that trace between the 2 pads should be in place. I hate to task but you tested your continuity meter was working before you tested the trace connection between the pads? Here is a video of Randy cutting the trace.
Watch the whole video as it show’s how he tests the compass later in the video. And some of the posts in that video discussion are very helpful.

Thanks, Grant.

I’ve confirmed I’m wrong and you WILL need to cut the trace between the pads. The reason for this is there is only one I2C bus on the APM and when 2 compasses are connected we can’t tell which is the internal and which the external.

Thanks, Grant.

Hi. Thanks for the suggestions.

I double checked that my meter was working and made a short video


I’m still not convinced that attempting to remove the undetectable trace will help.

It turns out my board is probably a 2.6 and doesn’t have the on board compass. The person I bought it from indicated it was 2.5.

It finally clicked when I looked at the picture of the board on this page that shows the location of the on board mag, and I had an empty spot on my board.

When I double checked in Mission Planner without the external compass attached, the orientation of the “plane” was rotating when I rotated the APM, but the mx, my, and mz values weren’t changing. They only changed with the external compass attached and only when I rotated the external compass, not the APM.

Problem solved - newbie issue.