APD ESC Telemetry - Cube Orange Plus


I am having issues receiving ESC Telemetry from my APD40F3 series ESCs. From what I can tell I have set everything up correctly per the wiki, and per some other suggestions I have found in the forums here. I will do my best to list things that I have tried. My suspicion is that I need to set some options on the serial port that are not obvious, or something needs to be changed firmware on the Cube to enable this functionality.

Flight Controller: Cube Orange Plus
FC Ver. 4.3.0
APD ESC Ver. 2.2.1
Aux 1-4 for motor signal outputs, DSHOT150
All 4 ESC TLM wires connected to SERIAL2 RX pin
SERIAL2_OPTIONS = 16 (have also tried 32)

It’s been suggested the telemetry signal from these ESCs is inverted in some way. Curious if anyone else has got this working. I have in the past got a 80F3 APD ESC to talk to the CubeOrange+ before, so I’m amiss as to what is happening here and where to start troubleshooting.



I also have had the 80F3 APD ESCs reporting telemetry, haven’t tried the 40F3’s but they should be identical.
There is an option for “DShot/Betaflight Telemetry” but I cant remember what the default setting is. The other option is PWM telemetry, which you dont want.

When it works the ESC telem data shows in MissionPlanner Status screen when using the Motor Test.

DHSOT600 will be OK to use.

Are you getting the BLHELI telem in .bin logs but not showing onscreen in MissionPlanner?
Ensure SERIAL0_PROTOCOL is set to 2 for MAVLINK2, and serial 1 as well if you use a telemetry radio.

Hi Shawn,

The default setting for telemetry output on the APDs is the Betaflight type, particularly on ver 2.2.1 which is a configurable beta firmware. I saw the other options, but as you said those are incorrect for this use case.

I am aware of how to check if it is working, and have always had non zero values for ESC related data in the status tab, and no ESC related items in my .bin files. I have made sure to check while spinning a motor up, even though APD states that their ESCs just need a valid throttle signal to output TLM.

DSHOT600 is okay to use, yes, but with the length of the wiring to the ESC’s on this build, I am going with a lower rate DS protocol as per the APD docs. Unless the APDs only release data on the TLM line when hit with dshot600, 150 should be fine and is in line with the APD docs.

All Telemetry connections between AP and my GCS are MAVL2

I have seen you suggest SERIALX_OPTIONS = 16 as well as 32 to someone on another thread. Can you share the logic behind how you came to that conclusion? Might help make sense of why it’s not working on the CubeOrange+


Can you check the Messages tab in MissionPlanner and see what you’ve got for RCout
Something like RCOut: PWM:1-8 DS600:9-12

That message is also in the TLOG, not .bin log yet (but it’s being moved under a PR)

Previously for the Cube Orange I’ve definitely used SERIALx_OPTIONS = 16

Also on another non-Cube flight controller I’m using the same params

The only other related serial port thing I can think of changing is BRD_SER2_RTSCTS,0 but I’m fairly certain I didnt have to do that for ESC telem to work with a Cube Orange.

I have PWM out for 1-8 DS150 for 9-12 and I believe some more PWM after that.

I have tried SERIALx_OPTIONS, 16 on multiple UARTs with no luck.

I truly suspect something is amiss beyond the physical configurations and relevant params. Testing the 80s on the exact same setup should be revealing. I suspect it’s something on the APD end as to why the 40s are not working.

I don’t believe either of the UARTS that i have been using have flow control, so not sure about the suggested BRD parameter. I’ll give it a shot before I tear it down and test the 80s.

My 2 cents.
Cube Orange has always been troublesome on the serial ports. For FrSky S-Port telemetry all my Oranges sport an external diode to handle duplexing with just signal inversion being handled internally via serial_options. Haven’t used an Orange Plus yet, tho’.

[offtopic] Where’d you find the 40F3s ? I have one, bought 4-5 years ago, when APD launched them, but they’ve been out of stock everywhere ever since.

Interesting on the diode bit… I was thinking it might be something having to do with the way that the options are handled on the serial port. For some reason, you have to run RX pulldown on it to get telemetry out of the 80amp APDs. I assumed that these would be the same, but no dice even though I believe that the telemetry format is unchanged from that of any APD, or blheli ESC.

I had a single 80amp APD hooked up to this exact same Cube Orange+ and had telemetry working perfectly. I am going to do this with all four 80amp APDs I have just to verify this all works.

I’m still looking for an explanation from somewhere why RX_PULLDOWN (16) is needed for SERIALx OPTIONS for the APD telemetry. Something to do with the logic signal level used or something?

I have access to someone that had done some testing with them in the past and had a lot of them around. I had two sets but killed one recently, so now I have one set and 3 spares. I don’t think that they have plans to make them again, but I could be wrong. To the best of my knowledge they are working more on the larger models like the 80 and 120amp versions.

Hi Zane,
Definitely try other serial options, like pullup or nothing, to see what works. Let us know what you find.

You could always email APD and they’d probably tell you what should work


I have been in contact with APD already about this. They are interested in finding a resolution to this issue as well and have been quite responsive to my questions. I was also assured that telemetry is handled the same on the 40 and 80 amp versions, so no change in ardu params should be necessary between models. They confirmed that SERIAL_OPTIONS, 16 is correct.

I’m quite curious what is going on here. About to wire up the 80s to see what gives, as I am pretty sure they are going to work right off the bat.

Hello all,

I just connected up a single 80F3, and have telemetry using SERIALx_PROTOCOL, 16 and SERIALx_OPTIONS, 16. No struggle whatsoever. The next step is to hook up all 4 of them and make sure that I am getting telemetry from all of them at once. What I can say definitively at this point is that there really does seem to be a difference in how telemetry (likely logic voltage…?) is handled between the 80 and 40a variants.

I am going to report these findings back to APD and see what they say.