Anyone else have issues with Arming after initial power up

Exmpl. .bin:

I have a long standing problem where my Pixhawk will not ARM unless I power cycle the Pixhawk, then it ARMS without issue.

During the initial powerup MP posts:
Initial Power up (cannot ARM): The msg “Hardware safety switch” and “Gyros inconsistent” continuously repeats

2/8/2021 3:42:11 PM : PreArm: Gyros inconsistent
2/8/2021 3:42:11 PM : PreArm: Hardware safety switch
2/8/2021 3:41:41 PM : PreArm: EKF2 Yaw inconsistent by 37 deg
2/8/2021 3:41:41 PM : PreArm: Hardware safety switch
2/8/2021 3:41:12 PM : PreArm: EKF2 Yaw inconsistent by 33 deg
2/8/2021 3:41:12 PM : PreArm: Hardware safety switch
2/8/2021 3:40:12 PM : PreArm: EKF2 Yaw inconsistent by 25 deg
2/8/2021 3:40:12 PM : PreArm: Hardware safety switch
2/8/2021 3:39:41 PM : PreArm: Hardware safety switch
2/8/2021 3:39:12 PM : PreArm: EKF2 Yaw inconsistent by 24 deg
2/8/2021 3:39:12 PM : PreArm: Hardware safety switch
2/8/2021 3:39:09 PM : Frame: QUAD
2/8/2021 3:39:09 PM : RCOut: PWM:1-12
2/8/2021 :39:09 PM : ChibiOS: d4fce84e
2/8/2021 3:39:09 PM : fmuv2 00330017 31345103 36313935
2/8/2021 3:39:09 PM : ArduCopter V4.0.6 (13b6478d)
2/8/2021 3:38:44 PM : Frame: QUAD
2/8/2021 3:38:44 PM : ArduCopter V4.0.6 (13b6478d)
2/8/2021 3:38:42 PM : PreArm: Hardware safety switch
2/8/2021 3:38:39 PM : Frame: QUAD

After Cycling the Power, I can then ARM the Quad. after this list of messages posts:
2/8/2021 3:59:20 PM : PreArm: Hardware safety switch
2/8/2021 3:59:12 PM : EKF2 IMU0 is using GPS
2/8/2021 3:59:12 PM : EKF2 IMU1 is using GPS
2/8/2021 3:58:52 PM : u-blox 1 HW: 00080000 SW: 2.01 (75331)
2/8/2021 3:58:51 PM : PreArm: Hardware safety switch
2/8/2021 3:58:50 PM : GPS: u-blox 1 saving config
2/8/2021 3:58:47 PM : EKF2 IMU1 origin set
2/8/2021 3:58:47 PM : EKF2 IMU0 origin set
2/8/2021 3:58:38 PM : EKF2 IMU1 tilt alignment complete
2/8/2021 3:58:38 PM : EKF2 IMU0 tilt alignment complete
2/8/2021 3:58:37 PM : EKF2 IMU1 initial yaw alignment complete
2/8/2021 3:58:37 PM : EKF2 IMU0 initial yaw alignment complete
2/8/2021 3:58:35 PM : GPS 1: detected as u-blox at 115200 baud
2/8/2021 3:58:34 PM : Barometer 1 calibration complete
2/8/2021 3:58:33 PM : Calibrating barometer

**I have conducted mag. calibration more than once in an open area using Mavlink (RF) to reduce influence of metal objects. I have tried recal of the TX and several and ACC recal. Nothing seems to fix this issue except power cycle.

Probably temperature issues. Try to power it up for 5 minutes on the ground, then power cycle it and test if you can arm then.

amilcarlucas, I do not think it is a temp. issue. I have tried power up and letting it set for 15 min., no change, I still have to power cycle before I can ARM.

Power cycling when it is hot and stable IS the solution
That is my point.

I still have no way of avoiding that.

amilcarlucas, so you are saying you have to power cycle your Pixhawk to get it to ARM?

I live in Germany, it is cold here. Yes, I need to do that every time.

amilcarlucas, thanks for the info., you are the 1st that has been willing to confirm this issue. Isn’t this something that should be addressed in a PR??

There is already a PR that probably fixes it. It needs more testing. Stay tuned :slight_smile:

ok, I will be on the lookout

Yeah same here @acsrandd1 today I change fw 4.0.3 to 4.0.6 after I saw this messages every power cycle.

Also there is lots of altitude various , i will be post video later :v:

Also disable safety switch , every time accel calibration , and main thing is mag calibration only on “>40sec” how it’s possible , and when I try to some variance then , same time no any issues with the green bar all the way top of green bar

Is that a bug ?

Moksh, I have actually been posting about this issue in one form or another for about 2 months and finally some people are starting to pay attention and respond. So, thanks for responding!

Yeah I read your post but that time , my original pix was crash and won’t start to buy new one , new is 4.0.3 so I update and same thing happened ,

It’s mean we have a fmu v2 board that’s why we have same problem
so now there is new update let’s see what happens

Happy flying :slightly_smiling_face:

Just follow the procedure:

  1. power up the drone
  2. wait 4 minutes
  3. power down the drone
  4. power up the drone
  5. arm
  6. fly

No need for re-calibrations, unless the compass moved, or something changed in the drone.

Moksh, yea but I have 4.0.6 installed. Had same problem with 4.0.5!

All versions have this issue, but some newer versions complain more about it.

PS. Just because older versions complain less, does not mean that the problem is not there.

Pre-arm checks are a good thing. Or do you think otherwise?

In my opinion, Pre-Arm checks are critical to a good design. Without pre-arm checks the probability of failure becomes excessively high.

Part of my frustration with this particular problem is no one was responding to my queries. I was beginning to think this may be a significant issue that may lead to some major event and eventual mishap. Finally, a few people have begun to respond and now I have a better perspective on the problem i.e. realization this is sort of just how it is, which I can work with!

With that said, I know the dev. guys have a lot on their plate resolving more important issues. But, it does seem to make sense that this issue could be resolved. I am simply suggesting it be put on the list of things to resolve, not a high priority, but still an item that should be addressed at some point.

Look at this , and just start and yaw alignment ?
I heard on flight message through telemetry
Never heard on without on flight

And also , you can see altitude meter very very fluctuate

Altitude fluctuations are caused by the baro hardware, there is no software fix for that.

But when I’m on 4.0.3 then no change at all after update then this happening

Nope there is noting in 4.0.4 or 4.0.5 or 4.0.6 that changes it.
The problem was already present in 4.0.3.