Servers by jDrones

Antenna Tracker on Matek F405-WING

(John Collingwood) #1

I’ve built the antenna tracker firmware for the Matek F405-WING and uploaded it to the board.

Upload seemed to go well and all the antenna tracker specific parameters are showing in the parameter tree. However, the servos don’t move. I’m not actually sure what signal pins the servos should be connected to but I tried a servo on each pin and they never moved.

Does anyone have any experience of getting the antenna tracker firmware to work with this board?

Thanks

1 Like
(Peter Hall) #2

the servos wont do anything unless you have it tracking something

1 Like
(John Collingwood) #3

I’m just trying to test the servos at the moment, using the test button on the extended tuning page in Mission Planner. Just figured out the signal pin - S1 & S2 are where the signals are being outputted. How easy is it to change to S3 & S4 as S1 and 2 don’t have a 5V pin for the servo next to them whereas 3 and 4 do. I tried changing the channels in config.h but that didn’t seem to work.

1 Like
(Peter Hall) #4

you don’t need to change the code, just put tracker pitch (72) and yaw (71) on to those outputs using SERVO3_FUNCTION and SERVO4_FUNCTION.

1 Like
(John Collingwood) #5

Ah thanks, why didn’t I think of that 🤦

Thanks for the help

1 Like
(Rolf) #6

Unfortunately, there are current Tracker versions on the firmware server only for the Navaio hardeware.
http://firmware.ardupilot.org/AntennaTracker/latest/
The last Pixhawk beta version is from 2016. Versions for the new boards would be great.

Regards Rolf

1 Like
(Peter Hall) #7

there will be a new release soon ish, if you want a firmware i can build it for you

1 Like
(Rolf) #8

Thanks Peter, that would be great, if you could build the new release for a pixhawk 1 or better an omnibus f4 pro ?

Rolf

(Peter Hall) #9

Pixhawk 1 antennatracker.apj (667.4 KB)

and omnibus f4 pro antennatracker.apj (567.3 KB)

This is master with this https://github.com/ArduPilot/ardupilot/pull/10452 and this https://github.com/ArduPilot/ardupilot/pull/10492

2 Likes
(Rolf) #10

Superb, thanks a million

1 Like
(Rolf) #11

Flashing the new omnibus worked. First stable version of arduplane with booloader (arduplane_with_bl.hex), then follows the flashing of peters antennatracker.apj by missionplanner.

2 Likes
(Rolf) #12

Thanks Peter @iampete . Our test setup with a omnibus works well.

Question: Is it better to mount the compass so that it tilts with pitch or better on the rotating platform that the compass only turns with yaw ?

1 Like
(Peter Hall) #13

glad to hear its working, you will have to mount the compass with with flight controller on the pitch axis, otherwise it will confuse the ekf.

1 Like
(kuspower) #14

@iampete Hello Peter, could you please compile for me last version for pixhawk fmu v2?

thank you so much for your help.

1 Like
(Peter Hall) #15

I’m pleased to report tracker is now built for everything on the server
http://firmware.ardupilot.org/AntennaTracker/latest/

3 Likes
Pixhawk Mini as Antenna Tracker - Solid red light when booting
(Frankie Fung) #16

I don’t see these SERVO3_ and SERVO4_FUNCTION in MP 1.3.61., as I have similar problem not able to test the servo using TEST button.

Pls help. Thank you.

(Peter Hall) #17

are you running the new beta?

http://firmware.ardupilot.org/AntennaTracker/beta/

(Frankie Fung) #18

I was running the AT V1.0.0.

But I got the attached error message when flashing with the beta version from the link you gave. I tried the .hex FW with and without bl, for all the 3 versions of Pixhawk, 1 4 and 6. They did not work.

Before I used Pixhawk (Actually Pixhack 2.8.4), I used APM2.6 as the AT controller. The test button did work.

Pls help. Thank you.

(Peter Hall) #19

What flight controller are you using? sounds like a Pixhawk1? you want the .apj here

(Frankie Fung) #20

Hello Peter,

Thank you for your support. I managed to flash the .apj fw to my Pixhack. But test button still does not work.

So I changed the default setting of SERVO1_ and _2 FUNCTION all to zero, and then assign SERVO3_FUCTION to 72 and SERVO4_FUNCTION to 71. But the result is the same.

With this beta version, I cannot even check the REVERSE box, which seems inactive.

I am using Windows 7. I may try later with another PC running Windows 10.

Do you get your AT running without problem ? Do you use any setting in MP other than the default setting ?

Thanks.