Another compass question

I get a lot of compass changes even with the latest firmware… So is it fair to say any compass on i2c is external? Not including cam, just spi and i2c. I’ll get a HMC5883 show up sometimes and sometimes it’s missing. I’ll also get a i2c LIS3MDL on exteral. Or the LIS3MDL and a AK8963 spi but external as well. When the HMC5883 shows up on i2c, the AK8963 is supposed to be internal… I though SPI would only be internal given the issues running longer cable lengths. Here’s some different image caps from random boots.

What Flight Controller and what GPS/Compass modules(s)?

It’s an original Here compass/gps connected to a Black cube 2.1 running firmware 4.0.5rc2. Tried two other Here pucks with the same behavior. It’s so crazy, three boots and three different compass configs since I posted this 10 min ago. Here’s the last three boots and compass changes. Lost one, lost another and then gained two again lol!

Huh. So those are 1st gen GPS modules and Cube? I think someone with more knowledge than I of Cubes will have to reply. I have an old Here module ) and it has a different compass yet than yours.

Mine did this today.
I have a Pixracer with a Holybro GPS and an RM3100.
For some reason today I saw one compass come and go. Sorry I didn’t really make note of which one.

I’m getting some similar issues with a Here1+ and Here1 with 4.0.7 copter.
The FC could boot without any issues and with the correct compasses but the next boot i’m getting compass changes and compass missing.

Already reset the FC and reinstall the firmware multiple times, and still got this problem.

Any solution for this problem? Its annoying and looks dangerous to try to fly.

It seems to me there is a trend here because we have the same problems as described in the first post of the thread with first gen. Here+ unit and Black Cubes.
Did you found any solution @Joao_Marques and @X1Aero?

1 Like

Still no solution. :confused:

Has anyone tried BRD_BOOT_DELAY,1000 or even up to BRD_BOOT_DELAY,5000 when using CAN connected devices?

Yup I use it a delay of 3000 and found it not really needed. However I also found that it had no ill affects.

We now use BRD_BOOT_DELAY,1000 on everything since we had a couple of strange boots when using the batteries with more than 3 cells, like the spark and interference from connecting the battery was a bit too much. We’ve had no funny boots or issues since using the boot delay.

EDIT: just clarifying: My previous post asking if anyone was using the boot delay was in reference to the people posting in this discussion talking about strange compass ordering with each boot and did it solve their problems (or not).

Ha missed that. I should have read it.

I had the same problem with the Pixhawk Cube today. Also, I can’t do the Big Drone Compass Calibration. The command fails.

The two on board Pixhawk 2.1 mags are the AK8963 (integral to MPU-9350) and the LSM303D. Try unchecked external for those two and the other two as external. While searching I found it recommended to disable both on board mags as they are subject to too much interference. I’m doing such with my older first gen Pixhawk that has that LSM303D (as recommended by Randy). External look to be the only ones worth going by, others just confuse the flight controller with its error. I would say 2 external with good readings are better than 4 with half being interfered with.

1 Like

Agree, generally good advise. From the “I don’t know how many” multirotors I have built there have been very few where the FC internal Mag was useful. On Planes it’s a different story typically due to power isolation.

Those Mags on IMU’s are good for mobile phones, tablets, etc.

1 Like

I only have this problem of compass missing when i connect the uav with the lipo, as soon i connect the uav only with usb cable the problem is gone and the compass are working.

Anyone have and idea how to fix the problem?

João Marques is this a Pixhawk cube? What voltages are you seeing when connected to lipo vs usb? Maybe you have a power module issue or something in the flight controller power circuitry isn’t functioning properly and the added load of the external mags are pushing it over its capabilities? Need a bit more info…

Its a CUBE black and already tried with 2 boards and 2 diferent setups and the result is always the same.

Here+ with CUBE black (4.0.7) compass gone.

Tried with a Here3 with the same boards and cubes black and no errors.

Here+ looks to be UART serial for the GPS and i2c for the compass, whereas the Here3 is CAN, right? Is the GPS working on the Here+ or is that gone too? Maybe its an i2c issue?

Hi Derek,

As soon the compass is gone i lost the GPS satelites.

Could it be a firmware bug? i dont have this in the pre 4.0.0 firmware.