Servers by jDrones

Altitude goes up in Loiter mode

Hello, everybody.
I’m making Align450 with pixhawk mini.
Firmware is 4.0.7 latest(but I have same problem in 4.0.5)
I can fly acro and stabiliz mode, that is no problem.
But , when I switch to loiter mode, the altitude of the helicopter went up more and more.
RC 3 PWM is 1094.RC8 is in external govoner rmode 1579.
Please let me know solution of this situation.

Please post a link to your log file (*.bin) We will need to see all of the data in order to determine the issue.
Thanks,
Bill

Thank you very much for reply.
I uploaded the bin file.
https://drive.google.com/file/d/1aiZbC8zeofFI2mXbW6WaFsJni5ziJ0HR/view?usp=sharing
Thanks,
Nobu

Hello.
I’m sorry. I did not set the permission setting.
I re-upload the file.
https://drive.google.com/file/d/1aiZbC8zeofFI2mXbW6WaFsJni5ziJ0HR/view?usp=sharing
Thank you a lot.

@Nobu,
I think your issue deals with your setting for H_COL_MID. Here are your settings for collective
H_COL_MIN 1391
H_COL_MID 1627
H_COL_MAX 1750

H_COL_MID is used for two things

  1. it is the lowest collective setting that the autopilot can command in non-manual throttle modes like ALTHOLD, Loiter …
  2. it is the zero point for the mixing of collective to yaw

In your case, since H_COL_MID is set so high, the autopilot can’t reduce the collective to maintain zero climb rate.

So in the swashplate set up instructions (here), the users are instructed to set H_COL_MID to the PWM value that corresponds to collective blade pitch for zero thrust. Out of curiousity what is the corresponding blade pitch angle settings for H_COL_MIN, H_COL_MID and H_COL_MAX.

I hope this helps,
Regards,
Bill

Thank you so much for your big help.
I’ll try adjusting the H_COL_MID on next weekend.
And I report the result here.
I am grateful that you help me.
Thanks a lot.
Nobu.

Hello
I flied after setting you said.
The problem was fixed!!
No problem in loiter mode!
I am grateful that you help me.
Thanks a lot.
Nobu.

1 Like
Servers by jDrones