Altimeter always at 0.0

Hi everyone:

Have a 3DR Hexa C APM 2.5+, purchased fully assembled in April of this year with:
3DR Radio Telemetry Kit 915 Mhz (US)
MB1200 Sonar
Ublox GPS
Using: Misson Planner 1.2.67 mav 1.0

Everything else seems to function very well, but I’m getting no Altitude readings. I always get 3D GPS lock, and the magnetometer functions perfectly as well.

I’ve searched the forum and I’ve found instances where the magnetometer was erratic as well as the Altimeter, but nothing like this.

Do I have something configured incorrectly? Or is there something disconnected? I’m not sure where to start with this one.


Does this occur when powering the APM with either the USB or the Power Module/Telemetry radio?
Does the APM have the pink poly between the board and the top of the case?
Have you taken the top off of the APM case and looked at the barometer chip to make sure that there are no shorted traces around the chip and that the hole in the top is not plugged?
Use these Wiki instructions to open and reassemble the APM case: … -overview/
Make sure you do not over tighten the screws when reassembling the case.

[color=#0000BF]This seems to occur regardless of how I have it powered (I’ve never seen it register anything other than 0.0).

I have not taken the case apart yet (I will do so tonight) I looked at the board layout on the link that you sent, and I think I figured out which chip is the barometer based on the instructions to cover it if you don’t have the enclosure (the silver elongated chip with the openings at the top I would assume!)
I will inspect that tonight for solder/trace issues and also let you know if I have the pink foam over that portion of the board.

Does the control software allow for use of the 3D GPS lock to interpret altitude when you are higher than the sonar will function? Is that something that can be selected in MP? The reason I ask is ‘Loiter’ seems to function very well at higher altitudes (75-150 ft) so something must be giving the APM a reference for holding position.

Thank you for the prompt reply, I’ll take a look tonight and let you know my findings. I really hope I didn’t get a faulty board out of 3DR. While I purchased it back in April, we were moving so I left it in the box for protection until I had time to get it up and running, which is now 4 months later. I’ve only had it up in the air a handful of times and I’ve never seen any reading for altitude.[/color]

[color=#000080]Took the case off, and confirmed that the pink foam block is in place, and the holes don’t appear to be blocked in anyway.

There doesn’t appear to be any solder bridges/splatter, or damage around the chip. I attached the best photo I could capture. MEAS 561101BA03 barometer, altimeter Sensor.

Any ideas?



I believe that the GPS will send the APM altitude information as well as positional information. How that information is used by the APM in relation to the barometer input I do not know.
Have you tried testing the barometer using the CLI in the Terminal Mode?

[color=#0000BF]I haven’t used CLI in terminal mode yet, I’ll have to look into how to use it.

I noticed that my picture didn’t upload, I’ll try again with this post, but make it smaller (it high resolution and was 1.8M, probably too large)

I have also filed a help ticket with 3DR, but I have not had a response yet. I’ll try to ping them again, but since I’m not getting any Altitude feedback, I’m hesitant to attempt any Auto or Guided commands, even though loiter seems to function fairly well. Thoughts?


Here is how to use the CLI in the Terminal Mode: … apmcopter/

[color=#000080]hmm… Tried connecting to CLI, following the directions in the link. Terminal would not connect: “Could not open COM port” (was set to 115200).

There’s not switch on a 2.5+ right? I opened the case again after seeing what I think are directions for earlier APM levels.

no battery, first connect, etc.

ugh… not getting anywhere with this one and 3DR isn’t responding to my inquiry. I called them Monday morning. [/color]

You should not have a MavLink connection established before entering the Terminal Mode. Disconnect the MavLink connection then click on the Terminal Mode button. In most cases the CLI will come up without having to hit Enter three time. On my APM when I enter the Terminal Mode it says opening a Comm port and then I get the CLI prompt.


I finally heard back from 3DR. They also instructed me to go to Terminal mode and enter Test mode. The instructions they provided for testing the altimeter actually tipped me off as to what was going on:

Beyond V2.8.1 firmware, and a Mission Planner 1.2.40 or so the variable that Mission Planner uses to display altitude changed from ‘Altitude’ to ‘Barometer’ (why they would do that will likely be unveiled as development continues I assume)

My MP software (1.2.67) was looking for ‘Barometer’ while my APM (V2.8.1) was transmitting it under the variable ‘Altimeter’. DUH.

I had hesitated to upgrade to V3.0.0 when I heard some people were having trouble, not thinking that a critical variable like that had changed (I dont recall seeing it in any software release updates I had read, but perhaps I missed it). Sounds like V3.0.1 has a lot of the bugs worked out.

“Always make sure you are using the most updated versions of both software sets!!!”

Thank you for your help! Altimeter data is displaying correctly now.

Nice work! I have learned something here too!

Thx TCIII !!

Before I wrap this thread up I want to post some information that others might find helpful that I dug up in the course of researching a possible faulty Baro/Altimeter Chip:

Link to Baro/Altimeter Chip Spec Sheet:

and I attached a pin documented photo based on the spec and how it’s being used in our case: