Servers by jDrones

Align TREX 550 Dominator PX2


(Donavon Taves) #1

I’ve built several multirotors and a few planes, but my dad bought a helicopter. I have zero helicopter experience, and he has very little. However, since a Pixhawk can make most anything relatively easy to fly, he wanted to try one for its payload capacity. Short story just to say I have no idea what’s normal behavior, what I should be happy with, and what needs to be fixed. It has a PX2, Here GPS, and Mauch PL series power system, and then normal ESC/Motor/Servo/Gearing.

Everything is wired up per the manual, and it does in fact fly pretty well. I think. However, I have a few questions. How is throttle normally setup? The esc is still on stock settings (governing mode), and
I’ve seen there are a few different throttle options in MP.

On full forward flight, it flies quite stable, but sometimes it starts twitching on the yaw axis and the twitches get larger until I stop and then let it hover.

On full roll in either direction, it tends to yaw in that direction around 45 degrees.

How do you power the high voltage servos? They’re all on the PH2 rail, does that mean I need to up the BEC voltage to 8 and put it on the rail?

I’m used to (and very dependent) on AutoTune, and know very little about manually tuning. Helicopter tunes are something else altogether, so if someone could look at my logs and give advice that would be greatly appreciated.
https://drive.google.com/open?id=1JlD2-sdaihl1HRbbICvK72edJ05j8A2e
https://drive.google.com/open?id=1-_mg1-YZVNfWtZxDqW9mwFyGlExBiAsK


(Chris Olson) #2

Looking at your params it looks like you’re flying just on feedforward and the tail settings are going be a bit “loose” with the defaults.

Yes, for HV servos just run 8V to the servo rail.

If the ESC is using governor, then use H_RSC_MODE = 2 and set the H_RSC_SETPOINT to the headspeed you want. Make sure you have no throttle mixes in the radio and a channel 8 switch to turn the engine on and off.

Since you are used to AutoTune, just load this param file in it with Mission Planner from the full parameter list:
https://github.com/ChristopherOlson/ArduHeli/releases/download/v3.5.6/Copter3.5-MP-tune_defaults.param

AutoTune don’t work with heli’s but that param file will. You may have to adjust the ATC_RAT_YAW_VFF if the tail is too responsive to the stick by turning it down a bit to maybe .08 or so. If the tail is wiggly you may have to adjust the ATC_RAT_YAW_D down to .003 or so.

If the tail is still “loose” turn up the ATC_RAT_YAW_P a bit to maybe .30 or .32. But most heli’s those yaw settings “just work”.

On aileron and elevator if you want the heli to have higher angular acceleration when you full stick slam it, turn up the ATC_ACCEL_P_MAX and ATC_ACCEL_R_MAX to maybe 85000 or so.

If you want quicker or slower rate response adjust the ATC_RAT_PIT_VFF and ATC_RAT_RLL_VFF either up or down. .15 is usually good for 550. 700+ might like it around .17 to .18, small heli’s will like it down to maybe .12 or .13.

If it tends to be tail bouncy set the ATC_RAT_PIT_D to zero. If it’s still tail bouncy set the ATC_RAT_PIT_P to .035.

Same on aileron - if it wiggles or shakes in roll set the ATC_RAT_RLL_D to zero.

That should be it for your tuning.