Servers by jDrones

Airmode not keeping quad stable for flips/rolls w/throttle low

I’ll be interested to see the results of this discussion. I’m waiting for 2 motors for my 3" seemingly on the slowest of boats.

2 Likes

Hi every one yea do it the way you said there Billy,and Andy which parameter is the haronic notch please

INS_HNTCH_* - but do you have ESC telemetry?

I have not tried the notch filter yet. I will give that a shot and see if it helps. thank you. also very cool that you have Arducopter running on a 3 and 4 inch. any tips for keeping interference between components to a minimum on such tight builds?

Vibration is the killer - the main thing is to use harmonic notch, preferably with ESc telemetry.

If you are not using the harmonic notch then I suspect your problem is simply that you don’t have a very tight tune and when you encounter these high noise maneovres the control loops cannot cope (or have prioritized altitude over attitude or something). You will find that the harmonic notch and a retune will substantially improve this.

Also work your way through the tuning guide if you have not done so already

Interference - big cap on the battery and make sure your video / camera are well shielded and away from the GPS

1 Like

I was able to get some video of my issue as well as try the “idle up” workaround. it kind of worked but not satisfactorily. I will try setting up the dynamic notch filter tomorrow, but I feel like the gyro just shuts off completely when the quad goes over 90 degrees and throttle is down. https://youtu.be/_sh4RH1zog8

We really need to see a log. I guess I’m not quite understanding - if the throttle is at zero, why would the copter be stable? There is no thrust to do anything at all with.

LOG_BITMASK = 196607 I think from Leonard’s picture

I suspect one of two things are going on here.

  1. you are still using an arming mode that shuts down stabilization on minimum throttle
  2. you have not increased ATC_THR_MIX_MAN high enough as @dkemxr (Set it to 1 if you are sure your tune is stable).

Sorry but there are so many ways to set this up.

Wait,
I think he wants “Motor Interlock”.

I think he’s lowering throttle completely, and expecting the copter to still stabilize itself. And it will do that with “motor interlock” set up.

2 Likes

I am trying to have gyro stable flight and full authority of the quad while doing full flips and rolls and other acrobatic maneuvers where you also need to drop throttle to zero momentarily. “Air Mode” in other flight control software provides this by keeping the motors running at zero throttle enough so that the pids still give you full control. im discovering that Arducopter has an “airmode” feature but it doesn’t exactly work like it should and or the wiki documentation for setting it up is not complete because there is no mention of needing to use “motor interlock”

according to the wiki, if you disable arm/disarm on rudder, then airmode is enabled. I have my arm/disarm moved to a switch. so I thought it would be enabled. my atc_thr_mix_man value was at 1. should I bump that up to 2 or even 2.5?

what I want is “air mode” or the ability to be able to have control over the quad while inverted and throttle momentarily dropped to zero. on the wiki, there is no mention of needing to use motor interlock to achieve this. however, I believe this may just do what I want. I am going to try it today but I am a bit confused on how exactly to implement it. I have read in comments in here that you need to enable it on an RCx_OPTION. so that would give me the ability to turn motors on/off on a switch. do I need to use that in conjunction with an arm/disarm switch?

1 Like

I keep arm on my transmitter sticks.
So, I arm w/ the throttle/yaw stick. Then it’s armed but motors not spinning. Then I flip the switch I have assigned to motor interlock, which does use an RC channel. Then motors spin up, and will keep spinning until I flip the interlock switch again.
You do still need to arm, one way or another. The interlock does not arm as well as lock/unlock the motors.

1 Like

Leonard flys with it set to 2 - so that sounds like a good thing to check. But be careful, this will mean you get aggressive control when doing gentle maneuvers like landing, which I think is why it’s good to have arming on a switch

1 Like

ok I understand now. I am going to try raising atc_thr_mix_man to 2 and see if that gives me what im looking for, if not, I will move my arm/disarm back over to throttle/yaw and setup motor interlock on a switch (RC channel). I will report back in a few hrs my results. thank you!

1 Like

I think interlock on a switch accomplishes the same thing, though… You can cut power to the motors at touchdown or just above ground.

2 Likes

switch or stick, either way it acts as a sort of dual-stage arming similar to having a pre-arm setup. but unlike a pre-arm, you also get a dual-stage disarm. I wish there could be a slightly better implementation of airmode in Arducopter but if this works, ill be happy

1 Like

Can you point me at the part of the wiki you are referring to? I don’t think you need all these arming options, it just means you need to be more careful at takeoff and landing. Also make sure you have a really good tune before bumping MIX_MAN.

1 Like

here is the section of the wiki that talks about airmode and enabling it. unfortunately it is a bit confusing as the way its worded makes it sound as though simply moving your arm/disarm to an rc channel other than the throttle stick will enable it and there is no mention of having to use motor interlock
Screen Shot 2020-05-23 at 9.16.32 AM

1 Like

Interesting… I don’t think that was a thing, when I last read the wiki. Seems like maybe it’s supposed to do the exact same thing as interlock…

While you do still need to arm w/ interlock, you don’t need to disarm. It does that a few seconds after you flip the switch. There is a bit of a delay, though… I’ve accidentally killed the motors while flying, and just turned them back on and kept flying. .

1 Like
Servers by jDrones