Servers by jDrones

Ailerons setting on Buffalo FX-79

(Hunt0r) #8

Read the documentation.

(Piotr Markiewicz) #9

Not sure if elevon + separate elevators are supported. Just start with elevons like described here

(Toto Mauris) #10

I don’t have any elevator, only 2 ailerons, and 2 flaperons

(Piotr Markiewicz) #11

OK, ignore flaperons, just setup elevons

(Toto Mauris) #12

I need to arm the pixhawk to move the elevons (in MANUAL mode) ?

(Piotr Markiewicz) #13

No, you arm motor, elevons should move all time. If not check connections.

(Kikislater) #14

Safety switch needs to be press to move elevons

(Toto Mauris) #15

When the elevons are plugged into the CH1 and CH2, they are in neutral position, but no move and no connection problem

(Toto Mauris) #16

The servos move when I move the flying wing, but the servo doesn’t move when I roll (RC1_REV 1, RC2_REV 1, ELEVON_MIXING 0, ELEVON_OUTPUT 1)

(Toto Mauris) #17

I think that the elevons move according to the rc control when the mode is “INITIALIZING”, few seconds after the PX4 turn automatically in RTL mode and after that no manual control of servos

(Hunt0r) #18

People have written instructions, designed for beginners, to help you understand and troubleshoot your own problems. Please read them, and ask here with any questions.

(Toto Mauris) #19

In fact, when I reverse the throttle in “Radio Calibration”, the PX4 turn into RTL Mode

(Toto Mauris) #20

I have reversed the throttle directly in the RC and it works, but I have plugged the flaperons on RC5 and RC6 (AUX) and I have followed the “Flaperon setup” instructions but no move (I can see a “correct” Radio 5 value in “Radio Calibration”)

(Toto Mauris) #21

I think that my flaperons wiring on RC outputs is wrong : the two flaperons are connected to RC5 and RC6 at the right side of the RC1 aileron output ?

(Toto Mauris) #22

I have tested, they are no signal on RC5 and RC6 outputs, I don’t understand why


the RC5 input works

(Toto Mauris) #23

I have tested, they are no signal on RC5 and RC6 outputs.

I can’t found the problem, could you help me please ?

(Hunt0r) #24

I recommend you write a well-organized and detailed request for help. Start from “the beginning” by describing your setup and desired behavior. Next include the details of what you tried that worked (and didn’t work). Specifying to the processes and information that you followed from the main documentation will help others understand why that didn’t work for your case, and how to assist you.

(Toto Mauris) #25

The ailerons work with ELEVON_OUTPUT option, but the flaperons don’t move with Flaperon setup of “Flaperon Configuration” doc

(Toto Mauris) #26

I need to move the ailerons on others pins ?

(Toto Mauris) #27

I think that the problem is that I have two servos dedicated to flaps, and the documentation explain to use only 2 servos for flaps and ailerons “Flaperons use your 2 ailerons”

How can I set my 2 others servos only for flaps ?