Servers by jDrones

Ailerons setting on Buffalo FX-79


(Toto Mauris) #1

I’m newbie and I’m trying to set Pixhawk for a Buffalo FX-79 flying wing.

According to my understanding, we can set this with the ELEVON_OUTPUT value, but I known’t which value to set.


(Hunt0r) #2

I believe this information is provided in the standard documentation. docs.ardupilot.org


(Toto Mauris) #3

Thanks, but I don’t understand how wire the servos.

I have two servos for ailerons, and two for flaperons. but only one connector un PX4 for aileron


(Hunt0r) #4

If you have a Pixhawk, it has 8 “main” servo outputs, and 6 “auxiliary” servo outputs. With 14 connection spots, I don’t understand what you mean that you have “only one connector.”

Unless there’s something going on that I’m not understanding, the documentation will help you decide how to configure the autopilot so that it controls all your servos as you desire. Give it a thorough read-through and attempt to follow it’s suggestions.

Perhaps post back here if you read-and-follow it thoroughly, and it still doesn’t work for you?


(Toto Mauris) #5

I must plug the two aileron servos in CH1 and CH2 ?


(lucamax) #6

You must use a Y servo wire and plug in just one Pixhawk output


(Toto Mauris) #7

Its compatible with ELEVON_OUTPUT option ?


(Hunt0r) #8

Read the documentation. http://ardupilot.org/plane/docs/reversing-servos-and-setting-normalelevon-mode.html


(Piotr Markiewicz) #9

Not sure if elevon + separate elevators are supported. Just start with elevons like described here http://ardupilot.org/plane/docs/reversing-servos-and-setting-normalelevon-mode.html#new-style-elevon-mixing-setup-elevon-output-option


(Toto Mauris) #10

I don’t have any elevator, only 2 ailerons, and 2 flaperons


(Piotr Markiewicz) #11

OK, ignore flaperons, just setup elevons


(Toto Mauris) #12

I need to arm the pixhawk to move the elevons (in MANUAL mode) ?


(Piotr Markiewicz) #13

No, you arm motor, elevons should move all time. If not check connections.


(Kikislater) #14

Safety switch needs to be press to move elevons


(Toto Mauris) #15

When the elevons are plugged into the CH1 and CH2, they are in neutral position, but no move and no connection problem


(Toto Mauris) #16

The servos move when I move the flying wing, but the servo doesn’t move when I roll (RC1_REV 1, RC2_REV 1, ELEVON_MIXING 0, ELEVON_OUTPUT 1)


(Toto Mauris) #17

I think that the elevons move according to the rc control when the mode is “INITIALIZING”, few seconds after the PX4 turn automatically in RTL mode and after that no manual control of servos


(Hunt0r) #18

People have written instructions, designed for beginners, to help you understand and troubleshoot your own problems. Please read them, and ask here with any questions.

http://ardupilot.org/plane/index.html

http://ardupilot.org/plane/docs/apms-failsafe-function.html


(Toto Mauris) #19

In fact, when I reverse the throttle in “Radio Calibration”, the PX4 turn into RTL Mode


(Toto Mauris) #20

I have reversed the throttle directly in the RC and it works, but I have plugged the flaperons on RC5 and RC6 (AUX) and I have followed the “Flaperon setup” instructions but no move (I can see a “correct” Radio 5 value in “Radio Calibration”)