Servers by jDrones

Ahrs not healthy on arm

Hello!
I have an arm precheck failure : AHRS not healthy when I have INS precheck turned on.

Could you please recommend how I can fix it?

Of course I can disable INS validation but it is better to investigate the problem

Thanks!

Fixed by disabling compass because I don’t have any

I wrote an issue for the developers to look at in github: https://github.com/ArduPilot/ardupilot/issues/13110

Thank you for your report!

2 Likes

Disable ekf 2 and you could arm. I had same issue on my omnibus f4 v3 pro.
Look for ahrs in params (qgc), if I remember well : ek2_enable

Hello!
Do you mean disable Ekf2 filtering?
Hmmm… It’s too much for me. I prefer to have this feature enabled in my flight.
I’d just disabled magnetometer. Moreover, omnibus doesn’t have any.

Disable ekf2 is not a problem and it was like that until arduplane 3.4
Commercial solution like sensefly ebee flown without ekf. Ekf smooth your flight, if you use it as mission planning it’s better without ekf as it flies straight without smoothing curves …

Thanks for explaining this.
I will test disabling Ekf2 in my current build :slight_smile:

Servers by jDrones