AHRS EK3 not started message

AHRS EK3 not started error message. i turned off pre arm, but can’t arm noticed this was at one time a bug however i do have my compass working. This is with the KAKUTE F7 rotated arrow pointing up 270. Not sure how to disable.

8/19/2021 2:51:59 PM : KakuteF7 003E0028 30395104 32343633
8/19/2021 2:51:59 PM : ChibiOS: 08877972
8/19/2021 2:51:59 PM : ArduCopter V4.1.0-beta7 (96936aa4)

I ended up deleting my config and moved to stable and it’s gone now.

1 Like

The message, “EKF3 not started” can appear if AHRS_EKF_TYPE = 3 but EKF3_ENABLE = 0. The solution is to enable the EKF (EKF3_ENABLE = 1) or switch to EKF2 by setting AHRS_EKF_TYPE = 2.

Hope that helps.

1 Like

Thanks! back testing ArduCopter V4.1.0-beta7 (96936aa4) beta also fixed the battery monitor in the HUD not working unless i had user error.

Odd to get that error. AHRS_EKF_TYPE = 3 and EKF3_ENABLE = 3 are default for beta7 on the Kakute F7 (have a couple). And previous versions going back awhile.

Yea probably users error on my part I also have my FC rotated nose up along with the GPS went back to default prams then beta7.

Wondering what your most liked FC after setting up a few different ones?

The Matek H743’s. More flexible than F7’s, 2 IMU’s, lot’s of outputs and UARTS and 2Mb flash.