Acro Mode stick response sluggish

I have a strange issue with my Quad x while in Acro mode, the stick response is very sluggisch and its impossible to do a Flip or Roll or anything like this, when i switch back to stabilize everthing is acting fine again, stick response is fast and precisly. I have some expirience and i think i didn’t messup any parameters. Acro Trainer = 0
ACRO_RP_P = 10

The tuning i did with autone the values are pretty high especially ATC_ACCEL_P_MAX > 255000 is this maybe the issue ? in Stabilized its flying pretty nice.
Thanks for Help on this one.
Here the Log

Can you post your parameters?

attached the param file

2020-09-21 19-27-00.log.param (18.0 KB)

If you are trying to do flips or rolls then I am guessing this is not a large quad - in which case you do not have a good tune. Go through the tuning guide make sure you set your filters appropriately for your quad size and enable the harmonic notch. If you have done this correctly then for a 5" or less quad you will likely get values for ATC_ANG_PIT_P and ATC_ANG_RLL_P of 18 in autotune. The fact that you don’t indicates that you have some noise to deal with.

Once you have done all this reducing ATC_INPUT_TC may give you a crisper feel and increasing ACRO_RP_EXPO will accelerate faster into the maneouvres you are trying to do.

1 Like

ok i will go and check the tune, normally doing a autotune works fine for me but there are some new fearures i see the first time, it past some time since last ardupilot build. but why its flying good in stabilize? the issue is only in acro mode.

There is a problem here. Your MOT_THST_HOVER is below MOT_SPIN_ARM - try setting these to the actual values they should be MOT_SPIN_MIN also.

RATE.R tracks RATE.Rdes well (so not a tuning problem) but ATT.R is way behind ATT.RDes so something is not configured correctly. Following the tuning guide to the letter will likely fix this.

1 Like

i went thru the settings but there is no change in behaviour, it seems to me that now it is flying even smoother and precisly, agile in in Stabilize but in Acro mode its flying really quite no vibrations nothing but the stick inputs are very sluggish, with sluggish i mean that i have to give almost full roll stick until its starting to roll very slow and retarted. what could this be?

here a new Log

You haven’t tried this

Also, your tune looks a lot better - but there is a significant amount of noise. You need to configure the harmonic notch to get rid of this. Noise in your tune will feel like sluggishness - you need to get rid of the noise to get a locked-in tune.

FWIW these are my acro parameters for a very locked-in 3" quad:
Gecko3-Tuned4.1-EK3.param (20.2 KB)

thanks i will try it, but still not understand, there is a massiv gap between stabilize and acro mode. in stabilize it flys in my opinion very good crisp, locked in lets say on a scale from 1 to 10 where 10 is best its a 8 and in acro mode 1.
so there is significant something wrong. what you are telling me would have impact also on stabilize correct?

Those settings above will affect acro feel - ACRO_RP_EXPO in particular. However, seems a little weird. When you have fixed the noise issue can you send a log with you trying to do this with ATTITUDE_FAST logging on.

Thanks for help im sure you’re right if we talk about fine tuning but the behaviuor between Stabilize and Acro is way out of spec, in acro it is unflyable were in Stabilize its more than good for me very fast and locked in.could it be that there is any other issue i can figure out ? Any other idea ?
In This image you see Throttle Input (Blue) and In Yellow and Red the Graph shows Desired Roll against Roll, the curves are following nice.
In Stabilize you see how fast its rolling were in Acro its rolling Slooooowwwwwly :wink:

I tryed to set “ATC_INPUT_TC” to 0.05 and its very crisp in Stabilize there is a change for sure but not in Acro.

Here another Graph from the IMU axis xy an z better then that it cant be no Vibrations at all.

is it possible that i load the wrong firmware? this is a pixhawk mini and i think i have load the fm pixhawk 1

Post a log flying in acro with attitiude_fast enabled in the logs

this one should have it enabled

Yeah I can see the effect. Your INS_GYRO_FILTER seems to be at 20Hz again - should be 80.
Settings look correct. Can you try ATC_THR_MIX_MAN = 0.5?

To go sure i restarted from scratch and forgott to set the Filter, thanks.
I Tryed with ATC_THR_MIX_MAN 0.5 there is no significant change.

One last suggestion - set ANGLE_MAX back to 4500. It would be a bug if this makes any difference but worth trying.

Also any chance you can verify that the problem does not exist in master? That would eliminate your particular settings as the cause of the issue.

no did not make any difference to change the angel to default 4500.Do you mean the Master param ?

No I mean 4.1-dev -

i can try but usually for such a agressiv quad i would prefere to use the stable firmware, for latest i will have to proceed with special more care only for safety reasons.if you prefere i can do ?

I am flying a very aggressive quad on 4.1-dev without issue