Acro Mode problem

Hello everyone. While setting up my boat (Rover v4.1.5), I encountered a problem that in acro mode, when I put the gimbal to the left or right and then let it go to the neutral position, the motors do not stop working, but keep spinning. When it gives the gimbal up / down, there is no problem and after releasing the gas, the engines stop. So it turns out that the problem is only with the left / right directions, i.e. the steering window in the Basic tuning tab? I have a motor test done. The mot_thr_mini parameter is set to 20. After switching to acro, the engines are barely but working. When mot_thr_mini is set to 0, the motors stand still after switching to acro.
The problem only occurs in acro Mode. This is not in the manual. For 3 weeks now he has been trying to solve it with little success.

You probably have the left and right motors swapped around and have reversed your steering on your transmitter to compensate, so it’s ending up turning it faster rather than stopping it turning because the flight controller is trying to do the wrong thing.

1 Like


MOT_THR_MIN is used to compensate for ESC input deadzone. 20 is a very high value.
How did you come up with that value?
If the motors stop when you set MOT_THR_MIN to 0, that seems to be the solution.

1 Like

Connection of mini pixhawk motors:
Esc out 1 engine. Left
Esc out 3 right

Servo outputs tab in mp
Ch1 throttle left
Ch3 throttle right

This is how the reverses are made. In the servo outputs tab on channel 1 on the left engine. And in the radio calibration tab on channel 3

In the motor test tab in the percentage window, I gave it until the engines began to orbit slightly. Unfortunately, I had to reach 22% on 2 seconds of the test. And the engines had yet to start smoothly. Left at 20% and right at 22%. As a result, in the servo outputs tab I trimmed the left engines to 1499 and the right ones to 1508 so that they both started equally at 20%, and then I entered this value in thr_min_value 20.
However, when it is set and I turn on the acro, the motors work very gently. (really very slowly, they practically do not make full turns, they only tick). And it is enough to lower thr_min_value even to 15, after turning on acro there is silence.

Please give some more information about your rover and a parameter file would be helpful, too.
Things like FC, ESC/motor controller, motors can always be helpful.
One thing you can try is to set the steering “I” (ATC_STR_RAT_I) value to zero and see if the motors still turn in acro mode.

-Mini pix v1. 2 radiolink
-Rover 4.1.5
-autopilot Installed in a 2-motor boat
-frame class 1 Rover (I set Rover because in the boat, after completing the mission, it turned into a loiter and I wanted to avoid it)
-pilot steer Type 0

I will send the parameters when I get home from work, I can send the log, but I don’t know where to look for it.

Basic tuning tab is just before setting. Because of this, he wants to run the acro mode well, so that he can adjust it to the speed and steering window as well as turn max g and acro turn rate. That’s what I need acro mode for. And due to the fact that it does not work well, I think I will not be able to calibrate pid, turn max g and acro turn rate well. Am I wrong?

I noticed that if I set mot_thr_mini to 0 and I add the “P” value from the steering window from 0.2 to 1, then when I put the left or right stick and return to the middle position, the motors stop.
It only has to be mot_thr_min to 0. When it is 20 to eliminate the dead zone, the “P” change has no effect.

You should not be doing any reversing on the transmitter or pixhawk. If you have to reverse things then you have it connected wrong.

You shouldnt need 20% to make the motors turn you need to sort the motor deadband

Post a log so we can see exactly how you have set it up.

Please let me know where can I find this log so I can insert it?

In the radio calibration tab, I turned the throttle channel because when I put the stick up on my RC radio, the bar went down in the radio calibration tab.

And in the servo outputs tab, I gave revers on channel 1 because without it, the steering would have been reversed. Stick left forward, stick right backward, stick up, from what I remember, it spun right, and the stick went down to the left.

Thank you, I’ll come back from work and get it.

You have you have reversed inputs and reversed outputs, manual works because you have reversed the reverse so drives normal in manual mode. But the autopilot is only reversed once. You need to undo the reversing and make sure the motors actually go forwards when given a forward command.

If its brushed motors then swap the wires on the motor to reverse them.

I’ll check it at home. Works until 4 pm

When you put the throttle forward both those values should rise and the wheels should turn forwards.

If I turn off reverse in the servo outputs tab on channel 1, it does. It gives the stick forward and the motors rotate forward, i.e. to the right. This makes my boat turn left. In order for the boat to go forward, I had to set the engines to spin outwards. So left engine to the left and right engine to the right. Because of this, I did a reverse on 1 to achieve this. Because without it you go forward in the boat, i.e. turning the engines outside, took place when I put the stick to the left. And when I turned to the right, the engines turned inwards, which means the boat was sailing backwards.

Please explain to me why if my radio gives the stick forward, then in mp in the radio calibration tab on the throttle channel the bar went back. I don’t have any reverses or mixes on my radio. Everything off.
Because of this, I turned the reverse over there to make it good. Is it wrong?
In auto / guided mode the boat sails normally to the point. It is known, without pid, turn max g etc. configuration, it zigzags a bit, but it flows to point A, it does not spin around.

post a log so i can see what your doing otherwise we are just guessing.