Accels Inconsistent MatekH743

Hi @bnsgeyer ,
I am mounting an AP (Matek H743) in the front of an Heli with an inclination of 24 degrees of pitch.
After setting the custom orientation of AHRS and doing the acc calibration, I get the message “accs inconsistent”. I follow the temperature calibration of the accs, but after its finish, the AP still continues to send the message “accs inconsistent”.
This doesnt happen if we put the AP in 0 degrees of pitch (leveled). This behaviour I see with the other MatekH743 I have. What i am doing now is disabling the INS_USE2 by setting it to 0. Then the messages are gone. I experience this behaviour in the latest FW 4.1.1 RC1, but was also seen in the FW 4.1.0.
Is this a normal expected behaviour? Is it related to the AP being inclined and the acc1 and acc2 showing different data?
During this investigation also found another issue in the MatekH743: when we set the batt_monitor=4 and batt2_monitor=9, after arming and spull up the rotor, it doesnt show the current in batt1, while batt2 is showing the current (from ESC). Voltages are ok in both. But if I reverse the scenario and set the batt_monitor=9 and batt2_monitor=4 (after setting correctly the volt and curr pins accordingly 10,11), I can see both currents in the status. Any idea for this behaviour?

What parameters did you used to set the custom orientation?


@Pedro_Claro I don’t think you should be getting accels inconsistent messages after your calibration. I am not a hardware guy and don’t have the expertise to help with this. I would suggest moving this to the Copter 4.1 discuss category. You should probably break out the battery issue in another thread. Hopefully @rmackay9 or someone else can pick this up and help you with it.


Hi @rmackay9 ,
I made a mockup with 1 matekH743 v1 (left side) and the lastest MatekH743 v2 (right side). My intention is to prove that it is not possible to calibrate accels when the AP is tilted in any FW4.1 version with MatekH743 v1. The result is Accels inconsistent. With the latest MatekH743 v2 this issue is not happening.

Process of replicating the phenomenon for the MatekH743 v1:
reset to Defaults + ahrs_custom_pit=27,5 + ahrs_custom_roll=0 + ahrs_custom_yaw=180 + ahrs_orientation=100 + calibrate_accels + reboot
Result for Heli FW4.1.0 shows below “accels inconsistent”

Same procedure for the MatekH743 v2:
reset to Defaults + ahrs_custom_pit=24,9 + ahrs_custom_roll=0 + ahrs_custom_yaw=180 + ahrs_orientation=100 + calibrate_accels + reboot
Result is OK

Repeated the procedure for the Arducopter FW4.1.0 with MatekH743 v1, result is accels inconsistent. Also tried with the MatekH743 v2 but with this one no issues found.

Also tried downgrading to Arducopter FW4.07 with MatekH743 v1 and result is accels incosistent.

MatekH743 v2 has a new redundante IMU and maybe with new drivers and the issue is not there. Maybe the root cause for v1 is related to the board layout which is differente and there is some issue related to that. I wanted to highlight this problem as it can be just sw related. Right now I have the heli running by disabling the 2nd IMU.
Thank you for your patience!

@dkemxr @andyp1per Any idea on this issue? thx

I would calibrate the H743-Wing v1/2 with default values (on the table). Then set AHRS_CUSTOM_PIT to the desired value and mount.

Someone else was reporting issues with orientation of this board. I think you would need to take a photo of the IMUs on both boards to see if somehow the hwdef is wrong - it’s possible they have changed the orientation and the hwdef is only good for one.

I think you are on to it. This is what I see if I got the orientation right:

They are supposed to be different:

IMU Invensense SPI:icm20602 ROTATION_ROLL_180_YAW_270
IMU Invensensev3 SPI:icm42605 ROTATION_YAW_270
IMU Invensense SPI:mpu6000 ROTATION_ROLL_180_YAW_270

Just can’t quite figure out if the difference is right or wrong!

Perhaps no YAW on the 42605? But why no roll? I don’t know, getting a headache :slight_smile:

20602 should be the same as the MPU6000, which it looks like it is:

also its the V2 that works not the V1. So I am confused, looks correct to me.

Huh. Yea they all have the same axis orientation relative to the reference dot.



They have rotated the ICM4265 90 degress left in the MatekH743 v2 compared to the V1. The x is oriented on the y direction.

Maybe the Yaw in the V1 must be 180, and by luck we found an issue in the V2 that has also wrong definition. Maybe if we roll the V2 with some degrees it will also fail.

@Pedro_Claro did you figure it out? I’m facing the same issue with a MatekH743 v1.5

@anchovy No, as I did not get more support from this forum, I endup using the Matek v2

We are flying v1.5 without issue

Are you able to explain why the new IMU does not have roll rotation of 180 in the configuration?