AC4.0.7 -> 4.1.1 upgrade issue

Not sure if this was already explained elsewhere - I just upgraded my Cube Black from AC 4.0.7 to AC 4.1.1 in Mission Planner (Version I tried the fmuv3 and the CubeBlack apj files.
All went smooth, but after the upgrade, all parameters (except the IMU params) were identical with AC4.0.7. EKF is still set to EK2.
Do I need to enable EK3 manually? Any other parameters I need to change for AC4.1.1?

You activated EKF2 manually at some point, so the automated parameter update code decided to preserve your explicit wishes.

You need to manually enable EKF3 for it to switch.

Usually you do not need to change any parameters.

thanks @amilcarlucas.
I managed to enable EKF3 manually but I ran into the next problem.
After rebooting the cube, I cant no longer connect to mission planner.
I am getting now te error: “failed to initialize MAVFTP” when I try to connect to Mission Planner either via USB or via UDP.
I tried multiple reboots, no success so far. Any ideas?

Is it running Mavlink1 protocol on the USB or UDP? It should run Mavlink2

It runs Mavlink2.
Apparently the issue started when I set the parameter ADSB_TYPE to 1 (uAvionix-mavlink)
I am using a Avionix ADSB receiver. When I set it to 0 it works again.

EDIT: My Avionix ADSB is connected to Serial4. Protocol for Serial4 is set to Mavlink1. When I set SERIAL4_PROTOCOL to 2, I get an error when I update the parameters.
So there seems to be a change from AC4.0.7 to AC4.1.1. in the protocol handling?