Servers by jDrones

AC 4.0.2: false logging or broken sensors?

After upgrading from AC 3.6.11 NuttX to AC 4.0.2 I see a very strange behaviour in the logfiles.
The good news is that the copter still appears to fly well. Even in heavy winds it behaves reasonably stable. But when I look at the logs, something appears to be odd.

  1. vibe and clipping measurements are only sporadically recorded and clipping numbers are skyrocketing. This screenshot is from 7 short flights in heavy wind. This always worked OK in 3.6.

  2. Crazy baro drift. This screenshot compares the measurements from a LidarLite with the baro including temperature. While the lidar recordings reflect the actual flight. The baro is way off. In other flights, the baro drift exceeded more than 10 meters during one flight.

  3. Incomprehensive output of the dataflash autoanalysis in MP.
    Why am I getting an IMU mismatch?
    Why is NaNs a FAIL? (and what does NaNs mean overall?)
    Why is OpticalFlow a FAIL? At least according to the measured values for flow_x/body_x and flow_y/body_y should work ok.
    Why Test parameters FAIL?
    With the exception of the NaNs Fail everything else was OK with 3.6.
    log_autoanalysis155

I did several attempts to recalibrate but the problem still remains.
Is my Cube black toast or is it a defect in 4.0.2 or in MP?
Here is the link to the full dataflash log.
https://1drv.ms/u/s!AnKeW8KMoCcyhiMb9kF6WwfbQgGA?e=vSNwlU

Do you have a log of a flight where you are simply in a stable hover out of ground effect for a minute or so with 4.0.2? Auto Analysis in MP is not up to date, don’t bother with it. For example MAG_ENABLE isn’t found because that parameter doesn’t exist. However COMPASS_ENABLE does but it’s not checking for that…

Another log file of today with plenty of hovering. Same behavior as in the previous log, the baro is drifting away by about 10 meters, and the VIBE logging is pretty much nonsense.
I tried to calibrate the baro in the meantime with TCAL_ENABLED=2, this did not work either. After setting TCAL_ENABLED back to 1, the baro started to drift away again.
https://1drv.ms/u/s!AnKeW8KMoCcyx195dfYa3BeLUCGX?e=12wC6A

Note that the copter is sitting on the ground from 9:52:00 onwards.

I understand that the Auto Analysis is currently not usable, but why do I get those strange results on eg the Vibe parameters? Again, this always worked well on the same copter with AC 3.6.

I am on a Cube Green and have installed the 4.0.2 .apj file for Cube Black.

Servers by jDrones