A Newbie Needs Help :( pleaseeeeeeee

You should really read through the wiki for heli set up and watch the videos. I think most of your questions will be answered with that.
Here’s the link
Trad heli wiki

Will do - thanks a bunch

Hey guys I have another question, I’m sorry :frowning:

When I am setting up my helicopter I’m loading all the parameters suggested above, I’m setting up everything like the instructions say but a few weird things are happening.

First off, my tail servo seems to be randomly overhearting and I’m not sure why - when I plug the servo in I hear it moving, it doesn’t move after that and then it starts to overheat.

Second, my servos aren’t really being responsive in stabilize mode or I’m not sure if they should be. I turned the heli on and am trying to test the servo movement direction on the ground I’m in loiter mode --> is this a bad mode to test this in? What mode should I use for ground testing?

Also as I am testing the swashplat isn’t really responsive ?

The servos will be sluggish on the groun in stabilize mode.

1 Like

That sounds like a servo problem. The defaults we have for tail servo are for very fast servos so you can turn off the yaw rate VFF and D-gain if you want and see if makes a difference. But generally, when a servo gets hot just from plugging it in it is either running on the wrong voltage, there’s something wrong with the servo’s internal control board, or something wrong with the pot in it. Or it is binding up.

1 Like

Sounds good - I don’t know if I want to take a chance with this size of a bird so I’ll probably order a new servo (better one this time), but I will try changing those parameters and see if it does anyhting in the meantime!

Test your swashplate movements on the ground in stabilize mode. Loiter may do some funky things if it’s jumping around with the GPS signal

1 Like

Hey all - so I’m trying to fly my bird what I thought was setting it up correctly. My GPS lock and everything is good the problem seems to be the compass offsets? The Ardupilot is yelling at me “failed pre-arm” compass offsets too high…

I did try calibrating all three compasses? Should I just calibrate the external and not use the internal ones? Is this an interference issue?

Yes, I would recommend turning off the internal mag(s). Only the external is normally usable.

But you have abnormally high offset in the Z-axis on your external compass. It looks like there could be an external magnetic field interference there.

I will definitely try that - I also believe the high z offset is because I calibrated it in the lab I work out of which doubles as a machine shop - lots of interference there so I shall try to calibrate on the field itself for lack of interference.

Would bad compass calibration lead to the vehicle behaving weirdly or falling out of the sky or careening sideways or doing anything I should be aware of in loiter mode?

Not that I’m planning to try it I just want to have the information in case

Yes, the mag cal will affect it in Loiter. And you should be as far away as you can get from sources of magnetic interference when doing the calibration. Calibrating inside a machine shop is not a good idea.

1 Like

No matter what I do this calibration keeps failing - I did it in the middle of a field this time im not sure what’s wrong

I mean I could just fly in stabilize mode but I’d rather use loiter since its a camera drone

Are you sure that your compass orientation is set correctly?


Manufactures of GPS’ are really good at orienting the compasses, so that it does not line up with the arrow on the GPS unit. It’s super frustrating.

I’m not sure, Here’s a pic of my setup?


Is this wrong in some way? Do you need a clearer picture?

1 Like

Also in this link:

They day if it keeps failing to raise offsets to 2000 or something ? The max offset? What would raising COMPASS_OFS_MAX to 2000 do?

No matter where I calibrate I’m getting the ridiculous offset of -814 mg

  • Northern Hemisphere: - Z-component should be positive - when pitching the vehicle down, the X component should increase in value - when rolling the vehicle right, the Y component should increase in value

In the tuning window on Mission Planner, enable mx, my, mz. This will give you the compass readings.

2 things looking at your picture:
It’s a Here GPS. They are one of the manufactures, where the compass orientation does not line up with the arrow. (And conveniently don’t mention it anywhere). It may have been fixed in later revisions.
Ah, here:

Also, by placing the GPS that close to servos, etc, you are risking a lot of interference, I place mine out on the tailboom. (about a foot or so away from the main frame).

@Implicit I guess it might depend on something else, as on the same helicopter model I have a GPS on the same location, and it behaves extremely well (ie no variance of the mags), although a different model… :wink:

Yeah, which is why I said “risking” :D.

However, if you are chasing compass gremlins (and I’ve been there!), I’d recommend moving it as far away from potential sources of interference.