650 copter oscillates

Hello everyone.

My new 650 drone vibrates and I find no instability in the frame.
The frame and propeller are carbon fiber. 700 kv motors and 6000Ma battery
Could this be due to the propeller which is actually only a 10.50 while waiting for 12.60 which is adapted to the engine ??
Bin file and a foto attached.

Hello there!

You and I have very similar builds and I face the same issue. I am still a layman but I will try to help. I think we need to look into the IMU. Yours looks like this:

According to what smart people say, the numbers are within limits. My chart from the latest flight looks way worse and the quad is not visibly shaking like yours. So I don’t know the answer but I am very curious what other people think the problem is.

But hey, maybe one thing. Looking at your build. I see your flight controler is mounted on damping pads. I believe the Pixhawk should be mounted directly to the frame without these pads. Have you tried that?

as i fount this an autotune log file , could you please upload a log with at the least 1m hover in loiter or altholde mode?

I just looked at your log and it says the flight controller is in LOITER and AUTO TUNE. Auto Tune will make the aircraft twitch as it tunes roll, pitch, and yaw.

As Oldgazer pointed out Vibrations are very low, that’s good.
Vcc , the 5volts DC to the flight controller is a bit low. It’s about 4.9 volts and you really need about 5.1 - 5.3. You might need to get a better quality power brick. It’s not causing an issue now (as far as we know) but it could be a big problem one day.
Make sure you’ve only got one of the ESC’s power wires (BEC) plugged into the server supply rail - you dont want all their voltage regulators fighting with each other. I couldnt see close enough detail in the photo.

I would set these parameters and check a cautious test flight in ALTHOLD mode
If that’s working out OK, try some more pitch and roll stick movements and watch for oscillations - land if you need to. If there’s problems reduce all those PIDs by 10%.
If motors get hot reduce the D terms a little, like to 0.003.
Once you are happy with all that, do another Autotune.
Post another .bin log if you run into trouble, or after Autotune.

Changing the prop size later shouldnt need too much adjustment, just:
MOT_THST_EXPO , PSC_ACCZ_I and PSC_ACCZ_P after the new hover thrust value is learnt, then run a new Autotune.

I received yesterday some bigger props, 12.60 and I made some test flights with standard parameters without any autotune. The copter flies nice with good response but I still can se those vibrations. The props are balanced, motors are aligned, everything is checked to be stable. Attached the last log with loitering and alt hold.
Have a nice day out there my friends.

OK now we got many things from your log

your vibration is good but it have noisy pattern

we can see this noise in RATE values

your config is on slow logging so there is no PID values
but i can see noise in PID values by looking at DesPitch,Pitch and DesRoll,Roll

to solve problem first complete tuning process instruction (but dont run autotune) then configure harmonic notch filtering

after all do a test flight with this log bistmask

Thanks everyone for the help, I will set up tomorrow a harmonic notch filter and test it. Part of the reason for the restless run seems to be the 2818 700kv motor, which seems to be overloaded with the recommended propeller. I went down from 1260 to 1038 propeller and got a calmer ride. Now waiting for the Gartt 4108 500kv motor and 6S Lipos. To be continued…

Hi folk
I try to setupp the notch filter but on Mission Planner is the parameter [INS_HNTCH_MODE] not available and on the Log bitmask are only IMU1,IMU2 and IMU3 available to choose.
I run version 1.3.73 on Mission Planner and 4.03 on the Copter.

Make sure you set INS_HNTCH_ENABLE first before looking for any other parameters

The EKF filtering seems to work well, before and after.