4.1.0dev SBUS out rate?

Hello, first of all I read the docs to be a bit conflicting on this:
for plane 4.1.0dev there docs say
BRD_SBUS_OUT: SBUS output rate
SBUS default output rate
both control the SBUS-out rate. On my revo-mini FC, i can only see the SERVO_SBUS_RATE and when I change it (tested 25,33,50,100,111), the only resulting output rates (measured with oscilloscope) are 25Hz and 50Hz (I need 111Hz or at least 100Hz). Any ideas?

it is an enum, to get 100Hz use BRD_SBUS_OUT=3, for 150Hz use 4

I do not have a BRD_SBUS_OUT parameter, thats wat I was trying to say

only the SERVO_SBUS_RATE parameter and judging by the rage (25 to 250) it is not an enum

ahh, sorry, BRD_SBUS_OUT is only on boards with a IOMCU.
On the revo it is indeed SERVO_SBUS_RATE, but it won’t go faster than your loop rate. What is your SCHED_LOOP_RATE?

ah, thanks, that defaulted to 50Hz and I did not know that that has an effect. Now it works at 100Hz. There is therefor no way to set a sbus out rate of 111Hz? Are there any other (negative) effects with a 100Hz loop?

you could set SCHED_LOOP_RATE to 111

larger log files

ok, as the doc states the specific values (50,100, …) i did not know, that values inbetween are accaptable

cool, thanks

1 Like