4.0.3 has become very easy in entering GCS FS [SOLVED]

I noticed that 4.0.3 enter GCS much easier than 3.6.11.
We fly with GCS and microhard ip mesh and have had no probs with 3.6.11, we were using GCS FS and it was kicking in and going RTL when the link was lost for, i’d say, 3-4 seconds. Now on latest 4.0.3, on same hardware and same location the UAV has become almost unflyable, it enters FS very very often.

Could it be the timing of FS being too strict for people using ip mesh and GCS with joystick?

Maybe such configuration would need a more relaxed FS management, maybe a parameter to set the timeout to enter FS is needed for people using systems different from traditional radios.

@rmackay9 would like to know what you think about the subject and if it could be possible to have a parameter to have a custom timing for FS to kick in to take in account for systems that could have a slight delay while working but still perfectly functioning like in 3.6.11

I read on the wiki here: https://ardupilot.org/copter/docs/gcs-failsafe.html that the timing should be 5 seconds after receiving the last hearthbeat from GCS, but it looks al lot shorter than that.

p.s. i noticed the problem gets worse when using mavlink-router instead of mavproxy on the companion.


As you say the GCS failsafe should trigger if there haven’t been any heartbeat or rc-override messages received in the last 5 seconds. I’ve had a quick peek at the code and I don’t immediately see any bugs in the logic.

I’m wondering if perhaps you’re seeing an RC failsafe (aka throttle failsafe) instead of a GCS failsafe? Might be best to confirm with an onboard log

To get back to the behaviour you say in Copter-3.6.x it may be possible to just disable the GCS Failsafe. At least in Copter-3.6 it was pretty much not functioning at all. If you were seeing a failsafe with Copter-3.6 I suspect it was actually the RC failsafe.

Please disregard my comment, GCS works as it should, it was my setup at fault.

could you tell me what parameters you changed? because I have the same problem …