3DR Y6, Spektrum Radio calibration, Motors not spinning


I built the 3dr Y6 DIY Kit and I’m now in troubles to get it flying…
I have a DX6i with a AR6210 DSMX satellite RX. The satellite is connected on the SPKT/DSM Port on the Pixhawk.

Problem 1: I’m not able to calibrate the Radio control in APM-Planner2.0.16. If I click on “calibrate” it tells me always “Radio control is not active or turned on”. But if I move the throttle stick on the TX I see this in APM.

Problem 2: I’m able to arm the system with APM Planner. If i move the throttle stick, three motors are spinning, but not all six! Has this something to do with the TX calibration?

Compass, ESC’s and Accel-Calibration were all successful, also the 3DR telemetry Radio is working.

Can someone help me? Thank you!

Did you bind the Spektrum Remote (Satellite) receiver to your transmitter before trying to calibrate the transmitter?

@TCIII: Yes, I connected first the Spektrum Satellite receiver to the Spektrum receiver and I powered the Receiver from pixhawk. The orange led’s on the Receivers were blinking, after binding they were stable orange. After this I disconnected the satellite from the receiver and connected it directly to the pixhawk DSM port. Also the DX6i settings are on Plane, not Helicopter. Do I have to do special Settings on the DX6i?

Another hint: If I use QGroundControl I’m able to do the calibration of my Spektrum radio. But there is no configuration for an Y6 frame. I want to use the APMPlanner, but why is this not working? This drives me crazy :frowning:

With mission planner it’s possible to choose y6 copter and to calibrate my Spektrum. Things are getting better :wink: Tomorrow i will have a look at the motors, there could be a problem with the cabling from the PDB to the ESC’s.

Ok the motors are now ok. I had a mistake on the cabling between the ESC’s and the PDB.
I think i will try a testflight tomorrow.
But I’m still confused why the remote calibration is not working with apm planner.

Short update: The Hardware is now working ok. I still have the radio calibration issues with APM Planner, so I opened a thread for this in the Ground Control Software Board. I’ll try to close this issue here, thanks.