3DR radio telemetry but no parameters (or waypoints)

I’m using two 915 MHz 3dr radios with a APM 2.6, and I am also using the current version of Mission Planner (1.3.5).

I’ve spent a significant amount of time attempting to get these radios to work, and I keep having the same issue. When I try and connect the two radios together using the Mission Planner connect button, it hangs on a message saying “Getting Params…(Sysid 1 Compid 1)”, and then gives me a connection error.

The odd thing is, that it will connect when I use crtl+t in MP, and it will give me telemetry information. However, I cannot see any of the parameters, nor can I download or send waypoints to the APM.

I’ve tried adjusting the airspeed, updating the firmware (tested with SiK 1.7 and 1.9), updating Mission Planner, verifying that all the parameters in each radio are correct, verifying that I am using the correct baud rate. I even checked to see if any of the pins were poorly soldered. I’m unsure what else to check. If anyone has seen and solved this issue, help would be greatly appreciated.

I am having this same problem. I check my TX and RX but never can get the waypoint or param to load. Driving me nutz…

did anyone find resolution to this issue? I am experiencing the exact same problem.


I have the same problem. Is there no solution for it?
Thank you for your help!

did anyone get this working? my I can connect using ctrl + t but it will never able to download/upload any params

i have the same problem with sik1.9 firmware on Android Tablet and MissionPlanner on win XP. Downgrade to Radio Firmware SIK1.7 solved the problem here. i do not know what goes wrong but after downgrading parameters refreshed very quick and connection is very stable.