3DR Power module not measuring current


I’m running plane 3.5.2. Im using a 3dr power module. The voltage is calibrated correctly as given in the guide - http://ardupilot.org/copter/docs/common-power-module-configuration-in-mission-planner.html.

However, the current reading shows zero at all times. It fluctuates around 0.1A when throttle is idle and drops to zero when throttle is increased.

I have tried re calibrating the thing multiple times, and nothing seems to work.

got any ideas?

just noticed another thing-

When throttle isidle and the current is zero, IF i write the measured current as a high value, say 100A, then the calculated current fluctuates between 50 to 200A. When throttle is increased, the current calculated decreases rather than increasing as its supposed to.

I had not encountered this bug before in the last four months of using 3.5.2.

Solved it!

I recalled that one of the changes made was that the power module was resoldered and connected directly to the ESC without a plug. When this was done, the power module was soldered reverse. The input was connected to the ESC and the output to the battery. I quickly resoldered it and now, everything is back to normal.

In my view these 3DR power modules using a currents sensing resistor arent that great.
These, using a hall-effect current sense IC are a better bet.

I havent used these boards but I have used the ACS758 hall effect current sense IC which they use, which I just soldered direct inline in the ESC power lead close to my ESC.
It has many benefits over the type with a current sensing resistor. The sense output is completely electrically isolated from the junk on the ESC ground, so avoiding ground loops ( The sensor itself is powered from the FC, not the ESC). It has very low resistance so is very unlikely to overheat, unlike the sense resistor type, which requires a resistance to work. The only downside is that it is more expensive

1 Like