3DR Iris Plus Telemetry problems

Hello! I recently bought a used Iris Plus. I’ve spent the better part of the last 3 days researching and learning how to use/maintain this little drone. So far I’ve been doing pretty good.

I’m having two issues I can’t seem to fix or find anything on the internet about how to.

Main problem:

Tarot 2D-T gimble:

Yikes this was a struggle! I managed to get the gimble to operate properly gimble wise… (Still a little jitter here and there.) But I can’t for the life of me figure out how to get the remote control for tilt to work. In Mission planner, it shows that the radio and the tilt dial on the remote are sending/receiving. But no matter what I do I can’t get it to manually tilt from the remote.

I’ve done the firmware updates for both the gimble and its motors. Holy crap that was a pain in the butt! Windows 10 and its driver issues… I had to Virtual Box windows 7 to get the damn gimble software to work! But it worked! I was excited… thinking “Hey I can make it tilt now!”

Fired it up… STILL NO TILT!

I’m lost! HELP!

Hero 4 +
Tarot D2-T gimble
Iris Plus on Pixhawk
3DR telemetry radio
FrSKY Telemetry ( What’s the difference between this guy and the 3Dr one as it has both…)

I can supply pictures if needed. Everything works other than the manual tilt!

Second problem:

Okay so this one I feel is just my in-experience working against me.

I want to hook up my GoPro for a wireless camera setup so I can remote fly the drone. I ride FMX professionally and want to get a buddy to film some mid-flight backflips. Having the remote veiw makes this so much easier to be precice while flying. I’m open to alternatives to the gopro but would like to get it to work as is, if we can.

I have the Little black cable that runs from the gopro to the telemetry. Mini usb to two 3 port black connecters one for 5v the other i assume data transfer. My confusion is where do I connect this cable? From what I understand this cable (Gopro) has to connect to the telemitry so it can be transmitted to the ground 3dr unit that’s connected to a computer?

I can get the 3Dr 944MHz ground unit to connect through mission planner. So I have that connection working. Im just confused on how this GoPro connects… Is there any guides to this? Ive legitmatly spent the better part of the past 2 days trying to find anything that will send me the right direction.

From what i can tell i think i connect the black whires into this guy???

The cable:

I’m new to drones Please be nice XD. Thanks in advance for any help you might be able to provide! My frustration is real at the moment.

If anyone needs a guide on how to update the Tarots Firmware using windows 10 I can make one up. That was a huge process and from waht ive seen its a common problem no one knows how to fix.

I got ahold of the guy I bought it off of and he actually forgot to drop me the second 3dr telemetry thing so that explains the camera. Still working on the tilt though!

Be sure you have MNT_DEFLT_MODE set to 3 (RC Targeting) If you have it in mavlink it’s not going to work.

As for video, easiest way is going to be equip with a video transmitter, and typical FPV ground station with DVR ability.

Hey thanks for the reply! So it was set on 3. I did notice that the MNT_RC_TILT was set for RC9? Is this the radio channel? The nob on my remote is linked to channel 6, I switch the 9 to a 6 and still no luck…

Thanks again for the help. Is there a collection of “How to videos” or guides anywhere for the Iris? I tried the FB group and have been waiting for 3 days to be approved.

I got ahold of the guy I bought it off of and he actually forgot to drop me the second 3dr telemetry thing so that explains the camera. Still working on the tilt though!

Can someone who has the tilt working on a similar setup take screenshots of their parameters and also the Gimbles software configs? I want to see if the guy before me has it set funny. He was pretty into the drone scene. I’m sure hes on here somewhere.

Id ask him about all this but honestly I’ve bugged the guy enough lol.

This multi has a 3-axis, and running on dif channels than you are, you would substitute your numbers, but it might get you on the road. I feel for you, the first time I set one up it was a complete dumpster fire, and I, for the most part, stumbled into getting it working. (Who reads instructions, right?)

I just took out my 3DR Iris and here what I have set. Since I set this up the software has changed the names of this stuff.

SERV09_MAX = 1520
SERV09_MIN = 1000
SERV09_TRIM = 1000



Hey guys! Thanks again for the replies! Seems every solution that doesn’t work still teaches me something new haha!

I’m having fun with this lol.

I checked my parameters and its all good according to the values you guys have. So I’m guessing its not my settings.

I managed to get a little lucky on google, finding this wiring diagram for the gimble. I have red brown and orange wires… Most videos on youtube have Black and white or black and red. This diagram is the closest to what I have.

So you can imagine my excitement when I found this thinking once again " Woop I’ve got it this time" haha nope. still can’t tilt it.

I did notice that the blue led light is solid meaning that autopilot isn’t connected… what can cause this? Wiring? Maybe my red isn’t the green wire? Anyone else have the red brown orange wire setup?


I took the cover off to take a look at the pixhak connection. Looks like he has it wired into the aux out? Channel one for rown red and channel two for Orange.

In the diagram above it shows to connect to channel 8/7. So wouldn’t that be on the “main out” side of the board, seeing as it has channels 1-8?

2nd Edit:

All right, decided to switch the connections to 8/7 on the main side and still nothing! The led is solid blue. I mean it gimbles properly but no tilt still. What causes the gimble not to connect to auto pilot like this?

3rd Edit: the saga continues…

I managed to find a video on youtube that shows the pixhawk and tarot connections here:

So it’s now for sure properly wired and I get the blinking blue led now! Woop woop I’m so excited. Now to actually get it to tilt though… Turned it on and she went from 0 to 90 as if it was manually tilting but when I went to adjust it on the remote it didn’t do anything once again.

Gonna mess with the setting a bit and see what I can get out of that.

4th freaking edit: ( you entertained yet)

We’ve had some success!!! If I power the drone with the dial turned all the way too 100% it will tilt down from there once powered via the remote manually but it one tilt back up! We’er half way there man i can almost taste that freaking bacon! ( I’m actually cooking bacon lol)

5th and final edit!!! IT WORKS! I GOT IT!!! SUCCESS! It was wired wrong from the previous owner. Once i rewired it and changed the settings to positional instead of rate it worked! Thanks for the helps guys! Hope you get a kick outta this lol I did.

Now onto figuring out why my GPS wont lock… Hmmm. Controller only lands about 4 sats right now. Checked the gps antenna wires things and they’re connected and good.

1 Like