3DR Aero

I received a 3dr Aero RTF fly from 3D Robotics two weeks ago. I have been trying to follow the initial test flight procedure outlined here --> plane.ardupilot.com/wiki/flying/ … arduplane/

On the first flight I took off in FBWA mode and the airplane was bouncing up and down and left and right violently over correcting itself. I switched to manual mode and landed. A review of the PID’s showed the pre configured Pixhawk had the PID settings very high. I lowered the PID values in half and again tried FBWA mode which was much better.

I moved on to testing the RTL feature. I set the airplane in the middle of my field and powered it up there. The home position registered as verified by the flight plan window of mission planner. I took off in FBWA Mode and climbed to a spot of about 100’agl and 2000’ downfield. I switched the transmitter to RTL mode and the 3DR Aero increased thrust to full and started bouncing up and down in one and two foot hops as flew in a steep dive into the ground.

The aero frame was saved by dense brush and I flew it yesterday in FBWA mode doing simple takeoffs and landings with me in control and FBWA at all times. Everthing looked to be normal and I had a couple good takeoffs and landings. Then immediately after takeoff the plane imitated an uncommanded roll and spun into the ground. Midway through this process I switched into Manual mode as the throttle was non responsive in FBWA mode.

Can you please review the attached tlog of the most recent flight? Any pointers as to what went wrong would be great.

Did you do any setup or otherwise go through the configuration wizard in the Mission Planner? If you got it with RC already installed, you shouldn’t have had to touch anything; indeed, going through the wizard would have just wiped out the factory configuration (not good!). Normally, you should just be able to fly it in all modes, right out of the box.

You can compare the factory settings with yours by looking at the file github.com/diydrones/ardupilot/ … _RTF.param

Hope that helps :slight_smile:

Hi wbal,
I’ve had a quick look at your logs. I did the early test flights of the Aero for 3DR, and suggested the default tuning values for the first prototypes, so I’m fairly familiar with how it flies. I don’t have a final production aero though, so some of my advice may be a bit outdated.
A couple of things really stand out in your logs. The first if you have larger servo throws to what I had. The throw is the maximum range of the servo movements for aileron/elevator/rudder. I had a range of 1100 to 1900 for aileron, whereas you have 990 to 2016. That extra 236 of movement can make a big difference, and you would need smaller P gains as a result. The same goes for pitch and rudder throws.
I normally set my throws to make the plane comfortable to fly in manual mode, then adjust gains for the Pixhawk. Those throws in your log look a bit high to me.
The next thing I notice is that during the RTL your transmitter was giving a lot of pitch and roll input, as though you were trying to control the flight. The default in automatic modes like RTL is that the autopilot allows the pilot to override its flight control. This is called “stick mixing” and is controlled by the STICK_MIXING parameter. You had stick mixing enabled (which is the default) so the plane reacted when you used the sticks in RTL. Was that deliberate input or did something go wrong with how the receiver was getting signals from your transmitter?
The RTL flight shows the RTL mode ended with the plane at an altitude of about 55 meters. It was aiming for 80 meters (as that is what ALT_HOLD_RTL is set to), but it went lower due to pitch input from the transmitter.
The log shows it changing to STABILIZE after that and climbing, then switching to MANUAL and landing. I don’t see a crash in the log. Perhaps there is another log that shows your RTL crash?
If your gains are still not as good as you’d like then I’d recommend you have a look at the new AUTOTUNE mode available in the 3.0.2 firmware that I released yesterday. See the documentation here:
Cheers, Tridge

Hi again,
Another thing to double check is that the mode switches are setup to what you think they are. If you were not in the mode you thought you were then it would certainly explain your results.
Cheers, Tridge


No setup this is how it was delivered. It looks like it came in incorrectly setup by 3dr.


Thanks, Will compare to the delivered parameters and compare.

@ Tridge

From the controller I was in FBWA for takeoff up until I noticed the engine go full and the plane roll sharply right. At that point I switched to manual on the FLSKY Th9x that came with the Aero. Manual on that is both switches down. Looking at the log it appears it went into RTL mode.

I checked the Flight modes in pre-flight and the pixhawk registers them correctly as I switch through them.

On a previous flight that I cannot find the log folder in mission planner I attempted RTL and the plane went full throttle with a steep downward attitude. The PID’s were high and it bounced up and down as it flew to the ground.

80 meters with stick mixing would be great. I will rebuild and attempt another RTL mode flight. To confirm in RTL the throttle is controlled bythe pixhawk and it would enter a loiter at the home position at the ALT_HOLD_RTL altitude? Also this is meters above the start position not MSL?

Will try 3.02.

Thanks to all for help.