Servers by jDrones

3.8 Beta testing, motors won't spin

(James R) #1

I’m using 3.8v3 beta to get a twin engine plane working. Anyone know why when i arm my motors wont spin? Everything else works perfectly.

FlaperonDualMot.param (5.7 KB)

Edit: I’m trying out 3.8v3 because i would like to try some missions with a twin engine plane.

(James R) #2

Since no one is replying. Would it just be better to by-pass the auto-pilot for throttle management for now?

(hans bert) #3

had the same problem.

easy fix, just go to servo3 min/max settings and lower the min setting so the esc can arm.
default is 1100 what is to high for most escs.

(tridge) #4

hi, just noticed this discussion.
For twin engine planes, to get differential thrust on rudder you need to set two separate outputs to the two throttles. If the left throttle is on channel 5 and the right throttle is on channel 6 then you would set:
then also set the MIN/MAX values for those channels as @aamadeuss suggests
You can control how much differential thrust to apply with rudder using the RUDD_DT_GAIN parameter (it defaults to 10, meaning 10% differential thrust for full rudder input)

(faraz) #5

Sir, if differential thrust works on twin motor planes, can we use separate battery packs for each motor?