3.5.7 Acro Mode

Hi All,

Probably a silly question but i can’t seem to find my answer in searches.

Today i spent a fair amount of time getting my 450 to fly in Stabilise and Loiter modes. Even got things tracking well in Auto mode so i’m very happy. Towards the end i decided to venture into ACRO which is scary for me but regardless i had rather good success and found things controllable very controllable even for me.

Okay so the question at hand. Like Stabilise mode whereby you trim the collective to hover mid stick, the acro mode seems to have ACRO_THR_MID param which i set but i couldn’t seem to get things trimmed so that centre stick in acro more closely matches the hovering pitch in stabilise. Am i missing something? The Heli is running very low head speed so thrust to weight is very low but regardless it flies very well in stabilise and ultimately in acro just the centre stick region differs by a mile so changing modes is a quick dash for cash to compensate.

Anything i should be adjusting to help dial this in?


As far as I know the ACRO_THR_MID param does not adjust the mid position of the collective. Hopefully you understand that the acro collective range is dictated by the H_COL_MIN and H_COL_MAX where stabilize is dictated by the IM_STAB parameters. Since I don’t do aerobatics with my heli, my collective range between stabilize and acro is exactly the same thus my IM_STAB_COL_1 is 0 and IM_STAB_COL_4 is 1000. Now if you are doing aerobatics, typically the H_COL_MIN is set for like -10 deg and H_COL_MAX is set for 10 deg. So the user accepts that the hover collective will be above mid stick and the software is designed to provide a smooth transition between the collective positions.
Hopefully this helps!

Hi Bill,

I have my H_COL_MIN and H_COL_MAX set up as per the max Collective pitch range i would like and the H_COL_MID is set to zero pitch as this was where i understood it had to be from whatching the traditional Heli Setup videos made by @ChrisOlson. In the setup video it is stated that this paramater is of 0 degrees collective as opposed to setting a hover trim. MY IM_STAB_COL params are setup so that i hover mid stick. Are you suggesting that i set the H_COL_MID to my hover pitch? I would aggree that ACRO_THR_MID does not seem to be adjusting the throttle as expected rather i think may be part of the 3 point curve in 3.5.7 prior to going to the 5 point in 3.6 - I THINK…

I find things nicer to be centred around mid stick for stable hover but then again i am just starting so i don’t have good habbits of others to pull from in my setup. I there a right or wrong here or just good habbit?

I have no grand dreams of doing acrobatics either but learning Acro mode does cement some valuable flying skills with STABILISE a quick flick away to get out of trouble hopefully.

No, that is only used for the input of collective to yaw mixing. Post your param file and let me know what you have H_COL_MIN and H_COL_MAX set to as collective blade pitch.

No, don’t do that. That throttle mid parameter does not apply to helicopters at all. To get Acro to line up on collective you have to add headspeed until you get your IM_STAB_COL’s 2 & 3 to to be centered at 500 (2 at 450, 3 at 550).

H_COL_MIN and H_COL_MAX are set to what equates to ± 10 degrees of collective pitch with H_COL_MID bang on 0 degrees.

Flys comfortably with these settings in STAB and low headspeed 2800rpm but the girl is a bit heavier with the extra autopilot stuff onboard so a bit more collective than normal to hover.

450 working.param (13.7 KB)

I see, okay well i suppose in a low headspeed scenario trying to get smooth camera ship style flight characteristics, acro really isn’t a mode that makes sense to go to. I just wanted to flick between the two easily but if i need to start messing with throtle to do that i guess i’m not really into that. I was hoping to be able to easily shift the acro centre point up so that it brought hover to mid stick easily.

Cheers for your help mate!

To make the transition seamless between acro and stabilize, set H_COL_MIN and H_COL_MAX to -3 and 12 or values that you are using for stabilize so that you can set IM_STAB_COL_1 and IM_STAB_COL_4 to 0 and 1000. Especially is you never plan to do acrobatics

Ledgend! that’s a great idea and makes perfect sense to squash the acro travel up to match STAB.

I’ll give this a go tomorrow!


It appears that your hover stick is around 700 for the IM_STAB_COL. I would recommend that you center your hover collective blade pitch between M_STAB_COL_1 and IM_STAB_COL_4 using H_COL_MIN and H_COL_MAX That way IM_STAB_COL_2 and IM_STAB_COL_3 would be 400 and 600. And then when you switch to acro, your stick position for hover will be the same.

Hi Bill,

Yes that is true but then switching to POS HOLD or LOITER these settings would result in a significant jump in Altitude as i would no longer be at hover mid-stick in Stabilise and as discussed not in ACRO either.

It seems i am trying to balance a system through 3 modes of which 2 of them require more headspeed to generate the lift required to hover at lower collective values and get the collective at mid stick.

I’ve just been thinking about the idea to move the acro H_COL_MIN value up as suggested and running through in my mind i don’t think this would actually have the effect as desired. Or would it? I need to try it, can’t quite visualise the resulting collective curve in my head at the moment.

Yeah, the Acro flight mode must be understood here. Acro is really made for symmetric collective range. In 3D heli’s mid-stick is zero pitch.

No, if you follow Bill’s instructions you’ll get a mid-stick hover in Stabilize with the IM_STAB_COL’s centered on 500. Which will also make Acro hover at mid-stick.

I don’t believe in low-headspeed setups for helicopters. It doesn’t really help flight time all that significantly, and it severely hampers the helicopter’s performance. I adjust headspeed for the load on the heli so they hover at 4.5-5.5 degrees of pitch. So the governor is my mid-stick adjustment, with the idleup selected for the payload weight. The amount of lift you get from your rotor increases with the square of the blade tip speed.

Also be aware that the defaults in Acro are almost like Stabilize. There’s an Acro Trainer feature that is on by default. So it’s not real rate-mode unless you adjust the settings for that Acro Trainer.

Hi Chris,

I have turned Acro Trainer off as the first port of call.

I like the low headspeed sound to be honest and the machine just sounds less angry with the lower RPM. My vibes are below 5 so it’s not that, i just like it slow. But what you’re saying makes sense, so if it is the difference between a well tuned bird and one that is suboptimal i will take your advice and go back through the setup as suggested.


Well, the thing is, if you’re using 7-9 degrees to hover it’s going to be difficult to get Acro to line up. This can all be set up on the bench. Just put it in Acro and measure the blade pitch at mid-stick. That’s where you need to be hovering at to get it to line up on the collective. With most UAV setups running -3 to +11 that’s usually below 5 degrees of pitch, and that takes headspeed.

Hi guys,

This post moves away from ACRO mode so might need a new topic.

Okay so today i raised headspeed to the maximum that my KV/gear ratio allows. 3100 RPM. Immediatly there was a very fast but intermittent tail shake wich i could hear, only ever so slight but i could hear it. I fixed that by reducing to 3000RPM but i could tell there was somthing wrong with that approach but moved on. The heli flew well in STAB, was locked to a rail and very controllable. I was happy.

Switching to Loiter was the decline to frustration. Immediatly the heli went into a fast mid air collective hunt. Fast up and down changes in altitude only in collective. There was no appartent pitch or roll dominance, rather pure collective in the Z axis. I see in the log that PIDA.Des goes wild when switching to loiter.

I went through a couple of hours of trying to drop P values and eventually went back to 0 accross all PID values in Rate. One again the Heli still flew well even with no support and only FF values.

What am i missing and where should i go to troubleshoot a heli that flys well in STAB, Well in ACRO and yet just bobs rapidly up and down in the auto modes like ALT HOLD, POS HOLD and LOITER.

Does a flow diagram exist for the mechanics of where the various controllers interact and moreso which PARAMS are associated with each? I’m simply not familiair enough also as to what params are simply not even used in a Heli, Despite them being present. I think we covered one such param above which has no use in a heli but is present, ACRO_THR_MID.

Anyway, back to troubleshooting the auto modes. How do i proceed?


For me it looks like that you have ACCEL_Z_P to high. If you are using FW 3.6- the name of that param. has changed to PSC_ACCZ_P which is now default 0.3 and was 0.5 before as default.
Just set lower and see.

These are the settings on those params,


They are bog standard out of the box as they are no covered anywhere in the Traditional Heli tuning instructions. So do these params become active in auto modes do they?

I am on AC 3.5.7 at the moment

Yes, ACCEL_Z_P is to high. That is what the Heli is doing up and down when that value is set to high. Set it to 0.3 and it should stop it.

1 Like

Thanks, I’ll give this a go tomorrow!

Which modes use this param? Why would STAB not care about the ACCEL being too high, does it not deal with accelaration values to achieve the angles required that get fed to the rate controllers?