3.4.2 Throttle spikes upon Althold / Loiter

Something here I have not seen in previous versions. Most recently using 3.4rc6 successfully. I’m getting significant, repeatable jumps in throttle (and alt), when going into Althold or Loiter. This is not just from/to Stabilize (stick not centered, etc.).

Hover learn is on and appears to be working. Log and screen shot attached.

2016-11-23 13-30-44.bin (1.3 MB)
2016-11-23 13-30-44v342Rat10Acc10run2.log (2.9 MB)

Log complains about vibration on the auto analysis…that will most definitely cause the altitude changes you are seeing. What are you using to dampen vibrations on the FC? What FC are you using? Attaching graphs of both vibrations.

Thanks. It’s a 3dr Pixhawk on a stand like this.

The Z vibes are not great, but typical performance is good, minus these new jumps. I reverted to 3.4rc6. I actually saw some of these jumps, then got a Err 24-1. Is this the EKF lane switch? After that ekf solution index went from 0 to 1 and the jumps were gone for the rest of that flight. That would explain the differences in Z accel shown here. Hardware or calibration issue? I’ll re-calibrate right now.

I use something similar to that but it was 3d printed and not fiberglass. Not sure if that’s an issue. Calibration may be better but when you said you were only seeing it in loiter/alt hold my first thought was vibrations. Make sure you have no cables touching the FC also; that can cause erroneous vibration readings from a bouncing cable.

Thanks. That mismatch warning in the auto analysis pointed me towards that last picture. The two z accels had different values. Bad. This is after a recalibration. Much better.

Problem gone. I can improve the isolation, I’ll try that as I move forward.

New information!

The Z accel mismatch is from the tone emitted from the buzzer at mode switch! Check out how they only temporarily disagree at each beep.

I’m not quite certain why a full accel calibration seemed to clear up the issue before. I refitted another one of our multirotors, the buzzer is really close to the servo rail, and 1st check flight showed a huge jump at switch to alt hold. look out.

1 Like

This darn buzzer strikes again! It affected my IRIS as well. I think we will need to change the tones to others that have less effect on the IMU.
If moving the buzzer is difficult, it’s also possible to turn off the buzzer by setting NTF_BUZZ_ENABLE to zero.

1 Like

I discovered this today ! … PixFalcon (HK) on F450 (tarot) frame. Arducopter 3.4.3 (installed last evening in substitution of the previous 3.2.1 . Test to the field : At every -mode- change --> about 1 second of -full throttle- (no climb-rate), gaining about 6 -7 meters , then (leaving throttle in the middle) descent back (slowly) to the original height. For all the rest the flight is perfect (included way point mission in auto-mode with auto Landing). Note : at the end of the flight i just was playing in -alt hold- at about 5 meters height, when entered battery fail-safe (in such condition , i saw after, the buzzer bips continuosly…) it gone up at full-throttle overshooting the RTL height (and was not slowing down !) i moved mode switch forth n back and regained control , then landed safely in loiter mode. …very unpleasant behaviour … I think i’ve to turn off the buzzer by software as the pixfalcon has it phisically on the PCB
I’m going to download dataflash log . (just in case I’ll find something else interesting in the graph)


I had the same problem.
I had installed the buzzer over pixhawk and every time I changed mode of flight the drone would rise a few meters.
I positioned the buzzer on the frame and the problem is solved.
Please log in fact had high vibration when I changed mode of flight.

I confirm the problem solved after buzzer has been disabled by NTF_BUZZ_ENABLE = 0. Tested today (switching between stabilize , Loiter and Auto mode during the flight and final RTL for battery_fail_safe at the end --> All OK ! (apart not having the buzzer).