3.3V chip dead on 2nd APM

Hi there.
I bought a Hexa B with APM2.5 here in Germany. After installing the firmware I could not connect via MAVLink, it stopped when recieving the parameters. It was possible to connect via terminal but all setup or test functions for the sensors failed. Reading the forums, i figured it was due to the 3.3V chip, so I returned it and got a new one. The new one connected fine, I could set up everything, sensors were fine, and I was starting to finetune everything. Yesterday I tuned the PID setting, holding the copter in my hand in my appartement, powering it up with no problems at all. Today when I went to the field to fly it, the ABC LEDs weren’t on and I couldnt arm it. So I went home, tried to connect, but it timed out. After installing the Firmware again, MAVLink stopped when recieving parameters, so i connected via Terminal and had the same Problems as before. Dataflash, Magnetometers and Gyros are not working, so it seems it’s the 3.3V chip again. Does anyone know what’s causing this? is it an inferior part or could there be something wrong with my power module?
please help me, I just don’t want to bother my vendor again and again with this.

Kind Regards

I assume that you are powering your APM with the Power Module when it is not hooked to the PC through the USB port.
If you are not powering the APM through the Power Module when you are flying, how are you powering the APM?
If we cannot determine the cause of your regulator failure here, please post your issue with the APM over on our sister site: diydrones.com/

When connected to the PC, I power it via USB. When flying, it is powered via the powermodule. Neither way the ABC LEDs light up, only the “alive” LED and the Rx/Tx LEDs.

It worked fine yesterday.

The symptoms sound like an issue with the translator chip. It’s a fine-pitch chip, so there were some production issues a while back with it, but they’ve been solved for some time. Possibly your vendor has some older inventory? It might make sense to contact 3DR customer support directly for a RMA, which will ensure that you’ll get the current version of the board, which is not vulnerable to this issue.

@TCIII : When i look on google, there are some reports that that the newer TPS79133DBVR voltage regulator are burnt after a few flying hours and then let the 5V pass throw the chip(measured on the I²C pins). But reports like this are often not right or rather user failure !

So, can you confirm as developer that the APMs with this voltage regulator works really safe when they are correctly soldered(there are no problems with peak amps)???


Since I am only a Developer and not a 3DR engineer, you will have to contact 3DR Engineering to determine the suitability of that particular 3.3vdc regulator.
TCIII Developer

TC asked me to post in here. That voltage regulator is commonly damaged by plugging a servo connector in backwards causing the +5V to be shorted to ground. That doesn’t have to happen at the APM. It could happen some place else in the wiring of your vehicle. If you have done it twice I would check the wiring before fitting another working board.

Ok, so when everything is always(!) connectet right, there are no Problems with this Chip, that is good !
Thanks for the fast response !


Same issue here. 3.3 volts dead:

  • 0.06V on innermost pin of I2C port,
  • no Mavlink connection
  • diverse sensor related erros in terminal mode:
    • “No dataflash inserted”
    • “Failed to boot MPU6000 5 times”
    • “PANIC: AP_Baro::read unsuccesful for more than 500ms in AP_Baro::calibrate[1]”

However, I don’t see how I should have short-circuited the servos, as there’s only a single connection to the power Rail on my Arducopter and it WASN’T inverted.

The other problem is that I live in Brazil and I bought the APM in Germany. What would be an appropriate RMA procedure?