1M Span OctaH UAV- Poshold hover bad-Oscillations

Hi everyone,
I have a weird issue with Poshold.

-Switching to PoSHold in light winds causes diverging oscillations ending in real bad pitching angles and results in potential thrust loss and ends in crash.

System: 29inch Octa-H frame-
135kV Motors
Hover throttle at <40%
Good 2x CAN GPS

Tuned manually as well as auto tune

The drone flies great in stabilise but once poshold is enabled the oscillations start.

The same oscillations are seen during RTL, after drone reaches RTL Landing Altitude.

Can you post a link to a .bin log file? Sounds like tuning issues.

Here’s the log file

Is that the right log? I don’t see any evidence of it being in Position Hold. Stabilize and RTL from GCS.

Also, while I’m sure tuning will improve things the craft could use a bit more thrust/weight. In this log just prior to RTL when it’s not climbing, close to a Hover condition IOW, your average motor outputs is ~1700. Not much headroom left for stability. In other areas of the log some motors are commanded to ~max.

Apologies, here’s the log where the UAV is unstable in Position hold.
Thanks for your insight. I realize there is not much headroom left for stability, we’ll try to improve the response by tuning.

Hello, I have very similar problem. Octocopter with pixhawk cube orange, 30 inch propellers. Weight about 18kgs. The drone was flying excellently and was stabilized. Than without any changes, only after calibration IMU and Compass it starts to oscillate. Oscillating was growing more and more. I did try to lock PID settings in Mission planner, but the lock do not stay written in setup and after reboot it is unlocked. Could you help me with some advise how to set the drone (PIDs) and keep stable flying? When drone is in the air (for short time and unstable) then some PIDs are changed during flight. I am confused. Please help me.
Thank you
G!2020-12-04 15-35-30.bin (973.3 KB)

Your ATC _ACCEL_P/R_MAX values are off by a factor of 10. And set these:

I’m not sure MOT_BAT_VOLT_MAX
MOT_BAT_VOLT_MIN affect stability. I don’t understand how are ATC _ACCEL_P / R_MAX out by a factor of 10? The values are set to 18900 according to the propeller size setting chart. I also tried setting the 36700, but the drone is still not stable. I don’t understand how pids can change during flight when AUTOTUNE is not on and after calibration. The set values should remain the same.

And why switch “lock pitch and roll values” is not working.

Your parameter file shows this. Look for yourself:

Off by a factor of 10 for the suggested values for that props size and battery power (30"/12S).

Lock Pitch and Roll will not work if Pitch and Roll are different…

Well than …it looks like real error. Typing error unfortunately, which I didnt see. I will correct it on Monday? And some suggestion how to fix the PIDs settings remaining?

Set these:

And prepare to use the Dynamic Notch filter by setting INS_LOG_BAT_MASK to 1. make a ~60sec hover flight in AltHold. And then set the Dynamic Notch parameters based on the FFT. Then set INS_LOG_BAT_OPT to 2 and make another Flight, then review to see if the Filter is effective,

Then run Autotune.

As the Mandalorian says “This Is The Way”

Great :-). On Monday I will try everything. I will send you an echo.
Thank you.

I see you have aggression set to .05. This probably an OK place to start with a craft of that size but you will want to repeat Autotune to arrive at a .1 setting. It could be done gradually.

Yes I have got it on this value. But firstly I need to stabilize drone enough for ATUN. :slight_smile:

Today I’m check settings for safety on the drones. You’re right, I rewrote zero. Locked PIDs also work. Great. Thank you. Do you still have any recommendations on how to set PIDs for a stable flight before AUTOTUN? I lost all older and functional settings with those changes.
Is it really the case that during flight the drone can change the settings automatically if the settings are not locked?

1 Like

No. They will only change in Auto Tune. And that button won’t make any difference when running Autotune. As soon as P/R are different it will be unchecked.

You could set the PID’s all back to default. Not the filters though just the ATC Rate P/I/D values. If you want to know what the defaults are run the Simulator in Mission Planner and copy those values. Assuming you haven’t changed the Sim values for some reason.

The reason is that when something is added as payload, the hoover PWM is set to different value and PIDs are changed and drone starts to be unstable. I dont see it before. I supposed it is caused by newest firmware version of ArduCopter. The same changing of PIDs and instability was caused by adding of lidar obstacle avoidance. As I wrote…newer seen before.

PID’s are not changed from simply flying. MOT_THST_HOVER is if Learned is enabled which is the default. Are you talking about Autotune?

No, normal flight. Still not stable enough for autotun. So why is there a lock on PIDs, when PIDs cant be changed in the flight except Autotun?